Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
frood
Beiträge: 226
Registriert: 7. Okt 2008, 15:17

yForm (php): kein Antworttext nach Mail-Versand [SOLVED]

25. Jan 2017, 12:49

Moin,

ich habe ein Formular für Buchungsanfragen mit yForm in der PHP-Version erstellt.
Funktioniert alles, bis auf die Tatsache, dass ich keinen Antworttext ("answertext") bekomme:

Code: Alles auswählen

$yform = new rex_yform();
// $yform->setDebug(TRUE);
$yform->setObjectparams('form_action', rex_getUrl(REX_ARTICLE_ID,REX_CLANG_ID));
$yform->setObjectparams('real_field_names',1);
$yform->setObjectparams('submit_btn_label','Anfrage jetzt absenden');
$yform->setObjectparams('answertext','Vielen Dank für Ihre Anfrage.<br>Wir werden uns schnellst möglich mit Ihnen in Verbindung setzen.<br><br>Eine Kopie Ihrer Anfrage wurde an Ihre E-Mail-Adresse gesendet.');

$yform->setValueField('text', array("datepicker_anreise","Anreise am"));
$yform->setValidateField('empty', array("datepicker_anreise","Bitte geben Sie das gewünschte Anreisedatum an!"));
$yform->setValueField('text', array("datepicker_abreise","Abreise am"));
$yform->setValidateField('empty', array("datepicker_abreise","Bitte geben Sie das gewünschte Abreisedatum an!"));
$yform->setValueField('text', array("name","Nachname"));
$yform->setValidateField('empty', array("name","Bitte geben Sie Ihren Nachnamen an!"));
$yform->setValueField('text', array("vorname","Vorname"));
$yform->setValidateField('empty', array("vorname","Bitte geben Sie Ihren Vornamen an!"));
$yform->setValueField('text', array("str","Straße/Nr."));
$yform->setValidateField('empty', array("str","Bitte geben Sie Ihre Anschrift an!"));
$yform->setValueField('text', array("plz","PLZ"));
$yform->setValidateField('empty', array("plz","Bitte geben Sie Ihre Postleitzahl an!"));
$yform->setValueField('text', array("ort","Ort"));
$yform->setValidateField('empty', array("ort","Bitte geben Sie Ihren Wohnort an!"));
$yform->setValueField('text', array("tel","Telefon (opt.)"));
$yform->setValueField('text', array("email","E-Mail"));
$yform->setValidateField('empty', array("email","Bitte geben Sie Ihre E-Mail-Adresse an!"));
$yform->setValidateField('email', array("email", "Es wurde keine korrekte E-Mail-Adresse angegeben!"));
$yform->setValueField('textarea', array("anm","Anmerkungen"));
$yform->setValueField('checkbox', array("accept","Ich habe die <a href='".rex_getUrl(55)."' target='_blank'>AGB</a> und die <a href='".rex_getUrl(34)."' target='_blank'>Datenschutzerklärung</a> gelesen und akzeptiert."));
$yform->setValidateField('empty', array("accept","Bitte akzeptieren Sie die allgemeinen Geschäftsbedingungen und die Datenschutzerklärung!"));

$yform->setValueField('hidden', array("wohnung", $name_wohnung));
$yform->setValueField('hidden', array("haus", $name_haus));

$yform->setActionField('tpl2email', array("buchung", ""));
$yform->setActionField('tpl2email', array("buchung_copy", $yform->objparams['email']));

echo $yform->getForm();
Wo ist der Fehler?

Vielen Dank und Gruss, Frood

EDIT:
Ich habe eine Lösung gefunden:

Code: Alles auswählen

$yform->setObjectparams('answertext','Vielen Dank für Ihre Anfrage.<br>Wir werden uns schnellst möglich mit Ihnen in Verbindung setzen.<br><br>Eine Kopie Ihrer Anfrage wurde an Ihre E-Mail-Adresse gesendet.');
muss ersetzt werden durch

Code: Alles auswählen

$yform->setActionField('showtext',array('','Vielen Dank für Ihre Anfrage.<br>Wir werden uns schnellst möglich mit Ihnen in Verbindung setzen.<br><br>Eine Kopie Ihrer Anfrage wurde an Ihre E-Mail-Adresse gesendet.'));
Warum das funktioniert kann ich incht ganz nachvollziehen ... aber was soll's ;)

Benutzeravatar
alexplus
Beiträge: 210
Registriert: 13. Feb 2007, 15:03
Wohnort: Heilbronn
Kontaktdaten: Website

Re: yForm (php): kein Antworttext nach Mail-Versand [SOLVED]

29. Jan 2017, 21:29

Der Fehler ist mir auch kürzlich aufgefallen. Fürs Protokoll:
https://github.com/yakamara/redaxo_yform/issues/242

Zurück zu „AddOns / Packages [R5]“