Hallo, lieber Forum Benutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via https://slack.com/ viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen bei Fragen/Problemen aktuell die Frage (zusätzlich) im Slack zu stellen. Dort sind viele kompetente REDAXO Benutzer aktiv und beantworten gerne (Anfänger)Fragen.

Selbst einladen kannst Du dich hier: http://redaxo.org/slack/

Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

18. Mär 2013, 14:00

Danke für dein Angebot, aber können wir das nicht doch lieber hier schriftlich machen? Dann kann ich (und vielleicht auch andere Nutzer) alles besser nachvollziehen...

Ich habe z.B. die Seite http://developers.facebook.com/tools/comments zur Moderation von Kommentaren gefunden. Die Kommentare aus meinem Blog erscheinen dort jedoch nicht...

Benutzeravatar
seelenenergie
Beiträge: 52
Registriert: 31. Dez 2012, 18:29

Re: Neues einfaches Blogsystem [TvsBlog]

18. Mär 2013, 16:12

Ok,

ich nutze diese Funktion nicht mehr und arbeite daran eine Funktion zu erstellen das man wenn man möchte auf Twitter, Facebook und co. die Artikel direkt posten kann.....

Lass mich mal überlegen.....

Also, unter https://developers.facebook.com/apps musst du eine Anwendung erstellen. Bei der Erstellung dieser Anwendung bekommst eine Anwendungs- oder App-id.

Wenn du diese App-id hast, gehst du in die Konfiguration des Tvsblog. Dort steht an letzter Stelle: "Facebook_App_ID"

Hier dann einfach die App-id die du bekommen hast einfügen und dann sollte es funktionieren. :)

dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

18. Mär 2013, 18:56

So weit bin ich schon.
Ich habe bereits eine APP-ID, die ich auch in der Blog-Konfiguration an entsprechender Stelle eingefügt habe. Die Kommentarfunktion läuft auch bereits tadellos. Nur versteh' ich eben nicht, wie, bzw. wo ich die Kommentare moderieren kann...

Benutzeravatar
seelenenergie
Beiträge: 52
Registriert: 31. Dez 2012, 18:29

Re: Neues einfaches Blogsystem [TvsBlog]

18. Mär 2013, 19:53

oh man heute steh ich echt aufn Schlauch.....

Gehe mal mit Kursor auf einen Kommentar in deinem Blog. Rechts in der Ecke müsste dann entweder ein graues X oder ein Stift erscheinen. Dort kannst du löschen, bzw. bearbeiten......

Ich hoffe das hast du gemeint!

dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

18. Mär 2013, 23:37

Durchbruch!!!

Es lag daran, daß zusätzlich zum Eintrag der APP-ID in die Blog-Konfiguration eine weitere Code-Zeile im Head-Bereich des Seiten-Templates eingefügt werden muß, nämlich

Code: Alles auswählen

<meta property="fb:app_id" content="HIER_APP_ID_EINTRAGEN"/>
Danach lassen sich die Kommentare direkt auf der Web-Site verwalten.

Danke aber trotzdem für deine aktive Mithilfe, Christian!

Benutzeravatar
michaelwandel
Beiträge: 330
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

19. Mär 2013, 11:49

Hi Jungs,

schön das Ihr Euch zu helfen wisst, das mit dem Meta-Tag kann ich in die aktuell kommende Version 1.3 mal mit einbauen, so richtig glücklich bin ich mit der Facebook-Lösung aber selbst nicht.

Ich denke bis zum Ende der Woche wird aber die Version 1.3 kommen da hier der entscheidene Kick mit sprechenden URLs und Rexseo-Unterstützung endlich sehr fein klappt.

Mal schauen was wir in der nächsten Version mit Kommentarunterstützung so bauen, wird ja scheinbar öfter mal gefordert ;-)

Gruß, Michael :)

Benutzeravatar
seelenenergie
Beiträge: 52
Registriert: 31. Dez 2012, 18:29

Re: Neues einfaches Blogsystem [TvsBlog]

19. Mär 2013, 12:07

Hallo Dimitrij,

ist super das du es gefunden hast! Also, bei mir hat alles super damals auch ohne den weiteren Metatag funktioniert.

Weisst du, ein 5 minütiges Telefongespräch hätte es wahrscheinlich schneller klären können (beim schreiben kann man sehr schnell aneinander vorbei reden), welches man anschliessend hier zum Besten hätte geben können....

Lg
Christian

Benutzeravatar
seelenenergie
Beiträge: 52
Registriert: 31. Dez 2012, 18:29

Re: Neues einfaches Blogsystem [TvsBlog]

19. Mär 2013, 12:27

michaelwandel hat geschrieben:Hi Jungs,

schön das Ihr Euch zu helfen wisst, das mit dem Meta-Tag kann ich in die aktuell kommende Version 1.3 mal mit einbauen, so richtig glücklich bin ich mit der Facebook-Lösung aber selbst nicht.
Hey Michael,

ich war mit der Facebooklösung auch nicht zufrieden, weil alles was von Facebook kommt die Webseitenleistung sinken lässt. Habe mir das Modul: "MD Bookmarks v1.0" vorgeknüpft.....

Delicious, Facebook, Twitter überarbeitet und Google+ hinzugefügt. XHTML-Fehler beseitigt!

Ich denke das ist ne annehmbare individuelle Lösung geworden. :-)

Beispiellink: http://www.seelenfrequenz.com/de/blog/

Lg
Christian
Zuletzt geändert von seelenenergie am 3. Feb 2015, 18:26, insgesamt 1-mal geändert.

dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

21. Mär 2013, 10:36

Hallo Michael!

Erst einmal vorweg - ich finde dein Blog-Addon wirklich toll! Es ist nicht nur äußerst vielseitig in der Anwendung, sondern auch klar und verständlich im Aufbau. Vielen-vielen Dank dafür und auch dafür, daß du so aktiv an der Weiterentwicklung dieses Blogsystems arbeitest!

Ich möchte an dieser Stelle noch zwei Sachen anmerken, die mir bei der Arbeit mit dem Blog aufgefallen sind und die ich hier im Forum noch nicht (oder noch nicht ausführlich) beschrieben habe. Vielleicht hast du ja Verwendung dafür bei einer der nächsten Versionen...

1.) An zwei Stellen im Blog-Ausgabemodul musste ich bei der URL der einzelnen Blog-Artikel das "?" durch ein "&" ersetzen, damit die Blog-Beiträge auch einzeln aufrufbar sind. Das sind die Zeilen ca. 85 (direkt am Anfang der Ausgabe) und ca. 161 (im FacebookComment-Teil).

2.) Wieder Blog-Ausgabemodul. In ca. Zeile 161 (FacebookComment-Teil) habe ich $_SERVER["SERVER_NAME"] durch $REX['SERVER'] ersetzt. Natürlich habe ich auch gleichzeitig die entsprechenden URL-Angaben im Backend unter "System" angepasst. Erst dadurch ließen sich die einzelnen Blog-Beiträge auch über Facebook aufrufen. Bei der ersten Variante bekam ich immer folgende Fehlermeldung:

Code: Alles auswählen

Warnung: http://www.czepurnyi.deindex.php/?article_id=1%3Fpost_id%3D16 kann nicht aufgerufen werden.
Ich hoffe, ich habe alles einigermaßen verständlich aufgeschrieben.

Insgesamt schließe ich mich auch der Meinung an, daß die Facebook-Kommentarfunktion nicht die Ideallösung ist. Eine eingebaute Kommentarfunktion wäre natürlich vorteilhafter.

Viele Grüße,
Dimitrij

dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

21. Mär 2013, 10:46

Hallo Christian!
seelenenergie hat geschrieben:ist super das du es gefunden hast! Also, bei mir hat alles super damals auch ohne den weiteren Metatag funktioniert.
Vielleicht liegt es ja daran, daß sich die Systeme bei Facebook immer weiter entwickeln und verändern...
seelenenergie hat geschrieben:Weisst du, ein 5 minütiges Telefongespräch hätte es wahrscheinlich schneller klären können (beim schreiben kann man sehr schnell aneinander vorbei reden), welches man anschliessend hier zum Besten hätte geben können....
Dazu muß ich sagen, daß ich nicht der ganz große Experte im Programmieren bin (um es mal sehr-sehr vorsichtig auszudrücken) :D Daher ist es für mich, wie ich schon sagte, immer besser, wenn ich etwas habe, was ich mir mehrmals durchlesen kann.

Viele Grüße,
Dimitrij

skyflo
Beiträge: 20
Registriert: 1. Feb 2012, 14:34

Re: Neues einfaches Blogsystem [TvsBlog]

16. Jun 2013, 19:52

Hallo, ich habe jetzt den TvsBlog in Betrieb genommen, da ich einen einfachen Blog für Redaxo gesucht habe. Funktioniert sehr gut und ist ne tolle Sache.

Ein Problem hab ich aber: Ich gebe den Blog so aus, dass die einzelnen Blogeinträge immer maximal 4x nebeneinander ausgegeben werden. Wenn ich aber auf weiterlesen... klicke dann wird ja der gesamte Blogeintrag angezeigt aber leider halt so schmal wie ich es in der ".css" eingestellt habe. Besteht die Möglichkeit eine zusätzliche "class" einzufügen, dass der Artikel nach dem weiterlesen in einer anderen Breite angezeigt wird? Momentan ist das ja in der Voransicht mit gekürztem Text die ".tvsblog_entry".

Hab im Blogausgabe Modul bereits versucht was zu finden aber leider bin ich da ein ziemlicher Anfänger drin und konnte noch nix passendes finden.

Wäre super wenn man das machen könnte und ihr nen Tip habt!

Danke und Gruß
Florian

Benutzeravatar
michaelwandel
Beiträge: 330
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

17. Jun 2013, 08:12

HI :)

Mmh, das ist mal ne gute Idee, werde ich gleich mal machen und kommt ins nächste Update mit rein :-)

Gruß, Michael :-)

skyflo
Beiträge: 20
Registriert: 1. Feb 2012, 14:34

Re: Neues einfaches Blogsystem [TvsBlog]

17. Jun 2013, 14:22

michaelwandel hat geschrieben:HI :)

Mmh, das ist mal ne gute Idee, werde ich gleich mal machen und kommt ins nächste Update mit rein :-)

Gruß, Michael :-)
Das klingt ja gut....;-)

Ich habe gerade festgestellt, das wenn ich auf den Titel klicke nicht den gesamten Inhalt angezeigt bekomme er läd einfach die selbe Seite wieder. Habe das Beiträge "anteasern" ausgewählt und es wird der "weiterlesen" Link gezeigt und da funktioniert das auch. Soll das denn bei der Headline so sein?

Den weiterlesen Link habe ich jetzt raus gelöscht und wollte eigentlich nur über den Title zum gesamten Beitrag gehen. Da hab ich es bei gemerkt.

Benutzeravatar
michaelwandel
Beiträge: 330
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

18. Jun 2013, 08:44

HI :)

Mmh, das sollte so nicht sein, ausschlaggebend für die gesamte Darstellung des Posts ist die Übergabe der post_id bzw. der korrekten URL, das sollte der gleiche Link sein wie auf "Weiterlesen...", auch auf der Überschrift, check das doch mal :-)

Gruß, Michael :-)

skyflo
Beiträge: 20
Registriert: 1. Feb 2012, 14:34

Re: Neues einfaches Blogsystem [TvsBlog]

22. Jun 2013, 18:50

Also auf weiterlesen komt das hier: http://beispiel.de/index.php?article_id=1&post_id=4 und auf dem Titel: http://www.beispiel.de/index.php?article_id=1?post_id=4! Das was anders ist ist rot makiert.

Gruß, Florian

dcz
Beiträge: 53
Registriert: 6. Nov 2012, 23:45

Re: Neues einfaches Blogsystem [TvsBlog]

25. Jun 2013, 18:42

Hallo skyflo!

Das Problem hatte ich auch. Lösung: Du musst in der Blog-Ausgabe an der entsprechenden Stelle das Fragezeichen durch ein "&" ersetzen. Die genaue Zeile kann ich dir nicht sagen, auf jeden Fall kurz nach "// Ausgabe..."

Gruß,
Dimitrij
}

Benutzeravatar
michaelwandel
Beiträge: 330
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

26. Jun 2013, 12:43

HI :)

Das Problem ist, das bei nicht aktiviertem Rewriting ja die article_id per ? noch angehängt wird, bei eingeschaltetem Rewriting natürlich nicht, da brauche ich dann das ? als ersten Parametertrenner, weiß nicht ob rex_getUrl mit dem Separator-Array das eigenständig trennt, ich sollte auf jeden Fall mal 'ne saubere Abfrage machen ;-)

Gruß, Michael :)

bb_web
Beiträge: 29
Registriert: 28. Jul 2007, 08:56

Re: Neues einfaches Blogsystem [TvsBlog]

8. Sep 2013, 10:15

Hallo Michael, erstmal super Lob für dein Blogsystem, läuft super, schlank und echt stabil.
Ist genau das was ich gesucht habe. :lol: :lol: :lol:

Vielleicht mal 3 Anregungen:

Kommentarfunktion (wählbar/optionell) währe cool -- kann man da nicht auf RexComment zurückgreifen? (wenn Comunity installiert ist zb.)

Mehrfachauswahl für Kategorien -- manche Artikel passen ja auch in verschiedene Kategorien -- oder hab ich das übersehen?

Auswahl/ Anzeige schon bestehender Schlagworte bei der Artikeleingabe -- wenn andere User Blogartikel erstellen sollten sie ja wissen welche Schlagwörter schon vorhanden sind

also das dazu und nur mal so als Anregung und Anreiz weiterzumachen :twisted: :twisted:

Raid
Beiträge: 21
Registriert: 10. Dez 2008, 11:54

Re: Neues einfaches Blogsystem [TvsBlog]

24. Sep 2013, 08:46

Hallo,
eine kleine Frage, habe ich denn eine Chance das meine Blogbeiträge hübsche Rewrite URLs bekommen, aber meine anderen URLs (in Redaxo einfach Rewrite auf ein gestellt) normal bleiben?

Das Problemchen ist ja leider, wenn man RexSeo einbindet und aktiviert, dass dann alle URLs sich verändern und wenn man ein paar Seiten gut im Ranking hat und da verändern sich die URLs, dass wird mir ein bisschen zu heiß ...

Benutzeravatar
RexDude
Beiträge: 2537
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

24. Sep 2013, 08:51

eine kleine Frage, habe ich denn eine Chance das meine Blogbeiträge hübsche Rewrite URLs bekommen, aber meine anderen URLs (in Redaxo einfach Rewrite auf ein gestellt) normal bleiben?
Nein, das geht nicht.
Das Problemchen ist ja leider, wenn man RexSeo einbindet und aktiviert, dass dann alle URLs sich verändern und wenn man ein paar Seiten gut im Ranking hat und da verändern sich die URLs, dass wird mir ein bisschen zu heiß ...
Für den Fall gibts in RexSEO eigentlich ne Option "Aufruf via article_id" die man dann auf "Zulässig, 301 Weiterleitung auf korrekte URL (ohne Parameter)" stellen kann.
Bzw. kann dir auch das Redirects Manager Plugin von RexSEO weiterhelfen, deine Urls sauber umzuleiten (z.B. für die TVSBlog URLs). Hab ich aber noch nicht ausprobiert.

Benutzeravatar
michaelwandel
Beiträge: 330
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Blogsystem [TvsBlog]

19. Nov 2013, 17:18

So, aktuelle Version 1.4.0 ist hiermit raus ;-)

Download wie immer hier: http://www.redaxo.org/de/download/addons/?addon_id=765

Änderungen siehe dort, wichtig aber, im Ausgabemodul wurde die Variable "keywords" gegen "tags" getauscht, da es nun neu Metatag-Felder gibt ;-)

Weiterhin klappt nun seo42 einwandfrei ;-)

Über den installer sollte ein Update einwandfrei funktionieren, auch über das manuelle reinkopieren, da die Ini-Datei nun nicht mehr vorhanden ist bzw. bei Bedarf generiert wird.

Hoffe es klappt alles wie gewünscht, viel Spaß :)

Michael :-)

skyflo
Beiträge: 20
Registriert: 1. Feb 2012, 14:34

Re: Neues einfaches Blogsystem [TvsBlog]

20. Jan 2014, 04:21

Hallo, hab mir jetzt auch die aktuelle Version installiert aber leider hab ich zwei Probleme. ;(

1. Die Umlaute werden nicht richtig dargestellt. In der letzten Version war alles noch richtig, was kann ich da jetzt machen?

2. Hab mir das SEO42 Addon installiert aber leider bekomme ich den kompletten Blogeintrag nur ohne Formatierung angezeigt, also "roh". Folgende URL wird angezeigt:

Code: Alles auswählen

http://www.meineseite.de/de/home/ecommerce/semrush-professionelle-software-fuer-seo-und-sem-professionals
Andere Seiten funktionieren und sehen so aus:

Code: Alles auswählen

http://www.meineseite.de/de/kontakt
Ich habe jetzt keinen Plan wie ich das ändern kann?

Danke und Grüße
Florian

Benutzeravatar
RexDude
Beiträge: 2537
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

20. Jan 2014, 09:13

1. Klingt so, als ob du evtl. den <meta charset="utf-8" /> nicht drin hast in deinem standard Template?
2. Klingt so, als ob du den Base-Tag evtl. nicht drin hast in deinem standard Template?

Für genauere Analysen müsstest du mal dein Template posten und evtl. auch die Debug Ausgabe von SEO42 (unter Hilfe). Oder vielleicht hat noch jemand anderes eine Idee.


skyflo
Beiträge: 20
Registriert: 1. Feb 2012, 14:34

Re: Neues einfaches Blogsystem [TvsBlog]

20. Jan 2014, 17:04

Danke! Ich hab das mit dem Schritt 2 und 3 total übersehen und nicht gemacht! Jetzt läuft es perfekt und auch das mit den Umlauten. Nur bei "Zurück zum Blog gehen" steht da immer noch "Zur¸ck zum Blog gehen". Wenn ich es im Modul ändern mit einem echten ü dann geht es natürlich. Was mir noch aufgefallen ist das da der Link auch noch so ausgegeben wird:

Code: Alles auswählen

http://www.meineseite.de/de/?tvsblog_start=0&tvsblog_category=-1

Zurück zu „AddOns [R4]“