Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

14. Okt 2015, 08:43

Moin,

so, hab mich nochmal damit befasst, und zwar so - gibt ja auch noch setDebug() -.-

Code: Alles auswählen

  $db2 = new rex_sql();
  $db2->setDebug();
  $db2->setQuery("INSERT INTO " . $REX['TABLE_PREFIX'] . $REX['ADDON']['rxid']['tvsblog']. "_categories SET title = 'Allgemein', create_date = " . time() . ", status = 1");
  var_dump($db2);
  echo rex_info("INSERT INTO " . $REX['TABLE_PREFIX'] . $REX['ADDON']['rxid']['tvsblog']. "_categories SET title = 'Allgemein', create_date = " . time() . ", status = 1");
Und bekomme dann folgende Fehlermeldung:

Code: Alles auswählen

Query: INSERT INTO rex_765_categories SET title = 'Allgemein', create_date = 1444804734, status = 1
Affected Rows: 0
Error Message: Table 'redaxo_db.rex_765_categories' doesn't exist
Error Code: 1146
object(rex_sql)#176 (14) { ["values"]=> array(0) { } ["fieldnames"]=> array(0) { } ["table"]=> string(0) "" ["wherevar"]=> string(0) "" ["query"]=> string(92) "INSERT INTO rex_765_categories SET title = 'Allgemein', create_date = 1444804734, status = 1" ["counter"]=> int(0) ["rows"]=> int(0) ["result"]=> bool(false) ["last_insert_id"]=> string(0) "" ["debugsql"]=> bool(true) ["identifier"]=> resource(67) of type (mysql link) ["DBID"]=> int(1) ["error"]=> string(55) "Table 'redaxo_db.rex_765_categories' doesn't exist" ["errno"]=> int(1146) }
Aaaaber das sollte doch nicht gehen, weil die install.sql ja vorher ausgeführt wird. Ich hab auch schon geschaut ob ich einen Typo hab / drin ist und den Code ans Ende der install.inc.php gesetzt. Ich finde aber keinen...

Also jemand eine Idee? :D
Danke für die Aufmerksamkeit
Gruß Tim

jochenheinz
Beiträge: 5
Registriert: 23. Feb 2014, 16:10

Re: Neues einfaches Blogsystem [TvsBlog]

31. Jan 2016, 18:10

Hallo zusammen,

ich habe ein kleines Problem mit dem TVSBlog Addon, das mich schon eine Weile beschäftigt und ich bisher nicht lösen konnte.

Die Installation hat ohne Probleme mit den kleinen Anpassungen hier aus dem Beitrag funktioniert und das Blog-Addon läuft soweit auch. Leider erhalte ich aber eine 404-Seite, sobald ich in der Artikelübersicht einen Artikel auswähle. In der Kombination mit SEO42 wird ja eine URL zu der Artikeldetailseite erzeugt, die so ausschaut: /blog/kategorie/artikel.html. Dies führt immer zu einer 404-Seite, wobei ein Aufruf von z.B. /blog.html?post_id=3 zu der richtigen Seite leitet.

Kennt einer von euch dieses Problem und kann mir einen Tipp geben?

Viele Grüße

Jochen

jochenheinz
Beiträge: 5
Registriert: 23. Feb 2014, 16:10

Re: Neues einfaches Blogsystem [TvsBlog]

2. Feb 2016, 17:28

Hat sich erledigt. Es war ein Fehler bei mir in der urlRewrite.inc.php

angel618
Beiträge: 23
Registriert: 15. Jan 2007, 15:57

Re: Neues einfaches Blogsystem [TvsBlog]

12. Mär 2016, 19:57

Hallo, habe TvsBlog 1.4.2 mit Rex 4.6.1 installiert.

Wenn ich das Blogausgabe Modul als Artikel Speichern will, zerstört es mir im Backend den Artikel. Ich kann keine Blöcke mehr einfügen und es wird nichts angezeigt. Kann nur die Kategorie löschen.

Ist der Fehler iwie bekannt ? An was liegt das ?

Danke

funkjewel
Beiträge: 3
Registriert: 6. Sep 2016, 12:08

Re: Neues einfaches Blogsystem [TvsBlog]

7. Sep 2016, 12:17

HILFE: FEHLERMELDUNG IN ANZEIGE ??!!

Hallo zusammen – ich bin ein absoluter Newbie in Sachen Redaxo. Komme eher aus der Print-Gestaltung… versteh mich aber gut in HTML +CSS. Alles andere ehr kryptisch (aber immer vertrauter).

Habe jetzt eine Redaxo (4.7) Seite zusammengebaut – und bis begeistert von mir :)
Und nun habe ich den TVSblog hinzugefügt und auch schon im entsprechenden Bereich den Test-Artikel veröffentlichen können.

Nur zeigt sich mir immer folgende Fehlermeldung unter dem Artikel:
Warning: mysql_result(tags): Initial error found in file xxx/redaxo/include/classes/class.rex_article.inc.php(126) : eval()'d code on line 210
WAS MUSS ICH ÄNDERN??
Meine Kenntnisse reichen leider nicht :?

vielleicht bekommen ich ja Antwort – wäre super!

THX
Julia

Benutzeravatar
michaelwandel
Beiträge: 321
Registriert: 1. Jul 2010, 13:54

Re: Neues einfaches Blogsystem [TvsBlog]

13. Sep 2016, 10:27

Hi,

sorry für die späte Antwort, benutzt Du einen Rewriter (Seo42, yRewrite) ?

Vielleicht kommt der Fehler daher ?

Kann es grade nicht so zuordnen, werde aber gleich mal ein frisches 4.7er installieren und testen ;-)

LG Michael :)

funkjewel
Beiträge: 3
Registriert: 6. Sep 2016, 12:08

Re: Neues einfaches Blogsystem [TvsBlog]

6. Okt 2016, 22:10

NOCH MAL FRAGE : SITEMAP/ NAVIGATION MIT ARTIKELÜBERSCHRIFTEN??

So Hallo,

ich werde immer besser :D :oops: 8)

Hab den Blog gestaltet bekommen – auch wenn ich noch nicht weiß, wie ich das mit den Bildern für die Kundin lösen soll (der tinyMce zeigt sie im BE nicht an und ich habe sie immer manuell über das html-Feld richtig formatiert.... any Lösungsvorschlag??)

Aber meine Hauptanliegen ist gerade: WIE BEKOMME ICH EINE SEITEN-NAVIGATION MIT ARTIKEL TITELN UND DATUM hin?
Meins Erachtens habe ich nur gefunden: Kategorien-Sitemap (modul_kategorien.rex) und timeline (modul_timeline.rex), da werden dann nur die Monate angezeigt.

Ich brauche eigentlich weder noch, sondern nur, dem Eingabedatum von oben nach unten folgend, eine Liste der Blogartikel, damit man sich sein (Interessens) Thema aussuchen kann.

WER HILFT MIR?? bitte bitte :lol:

Liebe Grüße
Julia

Benutzeravatar
michaelwandel
Beiträge: 321
Registriert: 1. Jul 2010, 13:54

Re: Neues einfaches Blogsystem [TvsBlog]

13. Okt 2016, 14:03

Hi,

einfach im Addon unter Hilfe das "Standardmodul" installieren lassen und dann irgendwo einbauen, das sollte reichen ;-)

Gruß, Michael :-)

Benutzeravatar
Kruge
Beiträge: 65
Registriert: 21. Feb 2008, 13:57
Kontaktdaten: Website

Facebookfunktionen?

21. Nov 2017, 19:26

Haaaallo!

Bin gerade dabei ein Blog mit tvsblog einzurichten und raufe mir inzwischen die eh schon recht lichten Haare: Ich komme mit der Facebookfunktionalität irgendwie gar nicht weiter, bzw. noch nicht einmal aus den Startlöchern. ^^

Vielleicht kann mich ja jemand in die richtige Richtung schubsen. :)

Also: Ich habe einen FB dev. Account und so eine FB-App-Nummer. Und nun?

Soll heißen: Anscheinend (so verstehe ich es) muß ich für dieses individuelle Blog nun eine FB App erstellen, damit das alles überhaupt was macht, richtig?

Aber wie/wo/was? Soll heißen: WAS muß ich da bei Facebook anlegen? Ich peil nix. ^^

Benutzeravatar
ds
Admin
Beiträge: 230
Registriert: 10. Okt 2006, 22:58
Wohnort: Berlin
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

21. Nov 2017, 20:21

Sorry, ich kann zu dem Thema nichts sagen. Ich möchte nur die Empfehlung abgeben, dass du mit Themen, die ein schrittweise Herantasten und vielleicht etwas Frage-Antwort-Ping-Pong erforderlich machen, am besten im Slack aufgehoben wärest. Dort kriegt man für gewöhnlich sehr schnell Hilfe (aktuell 315 Leute).

Eine Einladung zum Slack bekommst du hier: https://redaxo.org/slack/

Zurück zu „AddOns [R4]“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 17 Gäste