Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
joaopinto
Beiträge: 120
Registriert: 28. Jun 2006, 14:16
Wohnort: Österreich

template not found / R 3.2 nach Umzug

16. Mai 2013, 22:15

Grüßeuch,

für einen Kunden soll ich ein altes 3.2 System auf einen neuen Server umziehen.
Dabei habe ich 3.2 am neuen Host komplett neu installiert, dann die SQL-Daten von der alten Datenbank (mySQL4) in die neue (mySQL5) übertragen. Soweit alles funktioniert.
Installation hat auch geklappt, bis auf den Import der Files (Unterordner wie Lightbox werden nicht erstellt).
Im Backend sieht auch alles ganz okay aus, bis auf 2 Probleme:

- Im Frontend kommt: Nichts. Bis auf die Fehlermeldung, dass das mit der Startartikel verknüpfte Template nicht gefunden wird, also zB. "7 not found" und eine leere Seite. Templates sind aber alle da, auch in der DB, und auch zugewiesen. Ebenso die Startartikel ID.

- Im Backend erscheinen in den Blocks bei Texten Sonderzeichen als Fragezeichen. Gibt es hier ein Problem mit der Kodierung? Wo liegt der Fehler?

Vielen Dank im voraus für Eure Hilfe...

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

Re: template not found / R 3.2 nach Umzug

17. Mai 2013, 08:34

Hallo,

hast das neu Redaxo installiert oder das komplette Kopiert, hört sich nach nicht kopiert an.

Kopiere einfach per FTP alle Dateien und per dumper die DB.
dann änderst in der master.inc.php die DB zugangsdaten auf die neue und schon bist fertig.

Cheffchen

joaopinto
Beiträge: 120
Registriert: 28. Jun 2006, 14:16
Wohnort: Österreich

Re: template not found / R 3.2 nach Umzug

17. Mai 2013, 10:42

Hallo,

hast recht mit Kopieren klappt es, nur Erscheinen die Sonderzeichen im Frontend und Backend immer noch als Fragezeichen. Woran kann das liegen?

Leider klappt es mit dem Hochladen des Files Ordners per FTP auch nicht gut, da wird vieles nicht in den Medienpool übernommen. Und für die Importfunktion ist der gezippte Files-Ordner mit 45 MB leider zu groß.

Paolo

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

Re: template not found / R 3.2 nach Umzug

17. Mai 2013, 11:05

Hallo,

"?" da habe ich auch keine ahnung.
Codierung passt wo nicht aber wo, keine ahnung.
Hast alte DB per zb mysqldump gesichert und in neuer damit importiert?

Wie medienpool wird was nicht übernommen, wenn in alten die bilder drin hast und in der neuen per FTP wieder alles kopiert hast ist doch alles gleich.
Wenn redaxo einfach komplett kopiert hast (ausser master.inc) sind auch alle einstellungen gleich also bin ich überfragt.
PHP version ist jetzt nicht von PHP4 auf neu 5.4.12 oder so? denn soltest beim neuen die etwas runter schrauben.

Cheffchen

joaopinto
Beiträge: 120
Registriert: 28. Jun 2006, 14:16
Wohnort: Österreich

Re: template not found / R 3.2 nach Umzug

17. Mai 2013, 11:17

PHP am neuen Host ist nun 5.2.5, vielleicht liegt's daran (am alten PHP 4)... ist aber ein Provider, da kann ich leider nix herumschrauben.

Die alte DB habe ich über die Exportfunktion direkt in Redaxo exportiert und drüben wieder importiert.

Der Medienpool mag wie gesagt die über FTP hochgeladenen Daten nicht richtig erkennen, und über den Datenimport in Redaxo klappt das auch nicht.

So einfach wie es scheint ist der Umzug leider doch nicht, insbesondere wenn es sich um einen neueren Host handelt. Dafür ist alles zu fehleranfällig.

Danke jedenfalls für Deine Mithilfe.

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

Re: template not found / R 3.2 nach Umzug

17. Mai 2013, 11:34

Hallo,

also PHP5.2 dürfte keine problem machen.
Die alte DB habe ich über die Exportfunktion direkt in Redaxo exportiert und drüben wieder importiert.
ne nicht habe ich doch nun so ein zwei mal gesagt.
Kopiere einfach per FTP alle Dateien und per dumper die DB.
dann änderst in der master.inc.php die DB zugangsdaten auf die neue und schon bist fertig.
also im neuen, ein neu leere Datenbank anlegen und dannn per mysqldumper das alte importieren.

Das solltest schon mal so versuchen, sonnst drehst du und wir uns im kreis.

Cheffchen

Zurück zu „Allgemeines [R3]“