dpf_dd
Beiträge: 144
Registriert: 20. Dez 2007, 14:07

Extrem lange Ladezeit ("Time To First Byte")

4. Okt 2017, 12:59

Hallo Leute,

kurze Frage an die Experten.
Meine index.php vom Redaxo 4.6.2.-Backend hat beim Aufruf eines Artikels eine extrem lange "time to first load"-Zeit (> 5 Sek.) => siehe Screenshot.
Die Datenmenge ist mit ca. 8 kB vergleichsweise lächerlich gering.

Woran könnte das liegen und wie kann ich etwas genauer prüfen, woran es hängt? Jemand eine Idee?

Zur Info: Ich habe nicht gerade wenige AddOns am laufen und vermute daher ein Problem durch eine evtl. hohe Anzahl an SQL-Abfragen vor dem Laden. Ließe sich da evtl. herausfinden, welches AddOn für die Verzögerung sorgt?

Vielen Dank schonmal für eure Ideen, ich bin aktuell ziemlich ratlos wie ich weiter debuggen kann...

Bild

Benutzeravatar
anita
Beiträge: 682
Registriert: 25. Jan 2007, 10:25
Wohnort: Finsterwalde

Re: Extrem lange Ladezeit ("Time To First Byte")

4. Okt 2017, 15:08

vielleicht mal nacheinander die AddOns deaktivieren und schau mal nach, ob Du js oder css lädst, das Du nicht brauchst
Gruß Anita

javanita engineering, immer eine zündende Idee
http://www.javanita.com

dpf_dd
Beiträge: 144
Registriert: 20. Dez 2007, 14:07

Re: Extrem lange Ladezeit ("Time To First Byte")

17. Okt 2017, 09:40

Hallo Anita,

danke für deine Antwort und sorry, dass ich mich jetzt erst melden kann.
Leider ist das mit dem Ein- und Ausknipsen einzelner AddOns nicht möglich, da die meisten miteinander verknüpft sind und auch im Live-Einsatz von einer dahinterliegenden Redaktion bedient werden.
Da es sich um ein größeres Projekt handelt, habe ich zwar eine gespiegelte Dev-Umgebung - aber dort tritt der Fehler leider nicht auf... :?

Benutzeravatar
Thomas.Skerbis
Beiträge: 1271
Registriert: 4. Aug 2006, 14:06
Wohnort: Rheinberg
Kontaktdaten: Website AOL

Re: Extrem lange Ladezeit ("Time To First Byte")

17. Okt 2017, 10:13

Dann liegt es an der Umgebung?
Thomas Skerbis

Bild | KLXM Crossmedia / Werbeagentur in Moers | https://klxm.de

Tricks zu REDAXO
https://friendsofredaxo.github.io/tricks/

Benutzeravatar
anita
Beiträge: 682
Registriert: 25. Jan 2007, 10:25
Wohnort: Finsterwalde

Re: Extrem lange Ladezeit ("Time To First Byte")

17. Okt 2017, 12:22

klingt logisch
Gruß Anita

javanita engineering, immer eine zündende Idee
http://www.javanita.com

Zurück zu „Allgemeines [R4]“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 8 Gäste