Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
chip
Beiträge: 121
Registriert: 4. Mai 2006, 21:56

Multinewsletter Addon Feedback / Bugfix

31. Dez 2008, 01:20

Hallo,

zunächst einmal möchte ich mich für das grossartige Multinewsletter Addon bedanken. Sehr gut zu administrieren und wesentlich einfachere Handhabe aller Funktionen/Module.

Ich habe lediglich eine Anmerkung:

Damit die Unsubscribe-Funktion funktioniert, musste ich zwei Modifikationen vornehmen. Zum einen generiert das System die Bestätigungs-Links innerhalb der Confirmation-E-Mails mit einem &. Dies macht Probleme in meinem Firefox.

Hier muss in der Datei newsletter.inc.php folgendes ergänzt werden, ca. Zeile 308:

Code: Alles auswählen

              $subscribelink = str_replace("&", "&", $subscribelink);
Ausserdem muss, damit der Unsubscribe-Link funktioniert, folgender Code ersetzt werden, ca. Zeile 440:

Code: Alles auswählen

 // original    $subscribelink = $REX['ADDON375']['config']['root'].rex_getURL($REX['ADDON375']['config']['link'],$userdata['clang'],array('a'=>rawurlencode($userdata['email']),'k'=>$userdata['key']));
 // original    $subscribelink = str_replace("&", "&", $subscribelink);
            
                $subscribelink = $REX['ADDON375']['config']['root'].rex_getURL($REX['ADDON375']['config']['link'],$userdata['clang'],array('key'=>rawurlencode($userdata['email'].','.$userdata['key'])));
                $subscribelink = str_replace("&", "&", $subscribelink);
Ansonsten habe ich bislang keine Mängel gefunden - wie gesagt, ein super Addon!

Benutzeravatar
ciss
Beiträge: 359
Registriert: 8. Feb 2008, 05:24
Wohnort: Berlin

31. Dez 2008, 12:17

Huch, seit wann gibts das denn? Warte schon ewig sehnsüchtig auf eine Groupletter-Alternative. :?
Kein Support per PN. Probleme bitte im Forum schildern.

Tymo
Beiträge: 152
Registriert: 20. Nov 2006, 21:39

Fehler beim Multinewsletter

10. Jan 2009, 19:22

Ich erhalte beim Speichern der "Generellen Einstellungen" unter "Konfiguration" folgende Fehlermeldung:
Permission denied in redaxo/include/addons/multinewsletter/pages/config.inc.php on line 135

Warning: fwrite(): supplied argument is not a valid stream resource in redaxo/include/addons/multinewsletter/pages/config.inc.php on line 136

Warning: fclose(): supplied argument is not a valid stream resource in redaxo/include/addons/multinewsletter/pages/config.inc.php on line 137
Was läuft da nicht richtig?

Der Addon-Ordner "Multinewsletter" und die Datei "config.inc.php" im Ordner Pages haben von mir 777 Rechte bekommen.

Benutzeravatar
Mediastuttgart
Beiträge: 282
Registriert: 21. Mär 2005, 12:28
Kontaktdaten: Website

11. Jan 2009, 10:18

Hallo

ich habe mir das addon zwar nicht angesehen,
aber meine erste vermutung ist, dass die datei falsch verlinkt ist.

Code: Alles auswählen

redaxo/include/addons/multinewsletter/pages/config.inc.php
müsste die config.inc.php datei nicht nur im addon verzeichnis liegen?

Code: Alles auswählen

redaxo/include/addons/multinewsletter/config.inc.php
lg
michael
MEDIASTUTTGART, digitalisierte Kommunikation.

Tymo
Beiträge: 152
Registriert: 20. Nov 2006, 21:39

11. Jan 2009, 15:40

Hallo Mediastuttgart,

im Ordner "pages" und im Ordner "multinewsletter" liegen jeweils eine config.inc.php.

Das kann es dann wohl nicht sein.

Benutzeravatar
ciss
Beiträge: 359
Registriert: 8. Feb 2008, 05:24
Wohnort: Berlin

11. Jan 2009, 16:33

Hm, es wimmelt nur so vor Notices, und ein paar Warnungen sind auch dabei.
Ich würde bei der Addon-Entwicklung grundsätzlich mit error_reporting(E_ALL) arbeiten. Spart Zeit und Nerven.

@Tymo: Läuft dein Server zufällig unter Windows?
Kein Support per PN. Probleme bitte im Forum schildern.

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

12. Jan 2009, 23:44

Ich suche antstelle des groupletter Addons für 4.1 auch eine Alternative und teste das Addon.
Bei der Installation hatte ich folgenden Fehler:

Wrong parameter count for str_replace() in Zeile 35 in der config.inc.php

Nachdem ich mal

Code: Alles auswählen

$REX['ADDON375']['config']['root'] = 'http://'.str_replace('http://',$REX['SERVER']);
in

Code: Alles auswählen

  $REX['ADDON375']['config']['root'] = $REX['SERVER'];
geändert hatte, konnte ich installieren.
Bin gespannt wie's weitergeht ;)

Tymo
Beiträge: 152
Registriert: 20. Nov 2006, 21:39

18. Jan 2009, 19:02

Das klappt alles nicht. Mit der Anmerkung von Maidenaustria kann ich das Addon zwar installieren, bei der Konfiguration bleibt es aber bei den Fehlern.

Hat noch jemand einen Idee?

@ciss: Es ist ein Linux Server.

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

21. Jan 2009, 23:20

Hatte einen Fehler der leicht behoben werden konnte:

Code: Alles auswählen

/www/redaxo/include/addons/multinewsletter/files/.configfile
konnte Änderungen in der Konfiguration nicht gespeichert werden.
Einfach die Permissions ändern....




Nächster Test:
Beim Versand erhalte ich folgende Fehlerzeile:

Code: Alles auswählen

Warning: cannot yet handle MBCS in html_entity_decode()! in /www/redaxo/include/addons/multinewsletter/functions/basics.inc.php on line 406

an der Stelle ist zu finden:

Code: Alles auswählen

if($utf8) 
        $text = html_entity_decode($text, ENT_QUOTES, 'UTF-8');
      else
        $text = html_entity_decode($text, ENT_QUOTES);
Die Email wird trotzdem zugestellt, jedoch ohne aller Links Formatierungen usw....
Nicht das ich die ganze Webseite als Newsletter versenden will, lediglich ein paar Links wären eine Feine Sache...
Hat jemand eine Idee?


und nochwas: Geklärt!!
Irgendwie ist es nicht Möglich eine Gruppe anzulegen?!?!
Leidglich eine Checkbox und ein Feld für den Namen... kein "Speichern" oder "Übernehmen" oder sonst was...
Hat da jemand was dazu?
Lösung:
Einfach Häckchen setzen, Name eintragen und Enter... danach wird die Gruppe angelegt. Trotzdem wäre ein Button weniger verwirrend...



*testeweiter*
Zuletzt geändert von Maidenaustria am 31. Jan 2009, 00:15, insgesamt 1-mal geändert.

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

22. Jan 2009, 16:00

Beim Import und Export von Benutzern treten Probleme mit Namen mit Umlauten auf...

Fall 1:

ein User meldet sich mit dem Namen "Körner" online an.
Der Name wird korrekt im Backend angezeigt.
Beim Export in CSV wird der Name in "K?r" umgewandelt.

Fall 2:

Ein User wird manuell im Backend mit dem Namen "Körner" angelegt.
Der Name wird korrekt im Backend angezeigt.
Beim Export in CSV wird der Name in "K?r" umgewandelt.

Fall 3:

Ein User wird mit dem Namen "Körner" über ein CSV File eingelesen, so taucht der Name als "Körner" im Backend auf.

Auch die Meldung das eine Bestätigungsmail zugestellt wird, weist Umlaut-Fehler auf.
Auch die Auswahl ob "Weiblich/Männlich" hat einen Umlautfehler...


@chip: Bei Dir hat das alles ohne dieser "Bugs" funktioniert?!?!?!

*testeweiter*
Zuletzt geändert von Maidenaustria am 22. Jan 2009, 21:07, insgesamt 1-mal geändert.

Benutzeravatar
alex2911
Beiträge: 567
Registriert: 20. Jul 2005, 04:13
Wohnort: Österreich
Kontaktdaten: Website

22. Jan 2009, 18:13

..austria

hier dürfte das problem beim export liegen. schau dir den code mal an und spiel dich etwas mit encode/decode.

beim csv-import ists dasselbe :)

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

23. Jan 2009, 16:16

Danke für den Hinweis... Der Import funktioniert schon mal ganz gut, nachdem ich folgendes in der pages/import.inc.php
geändert habe:
Von:

Code: Alles auswählen

                
$importdata[] = array(
                  'email' => $user[$fieldnums['email']],
                  'firstname' => (empty($user[$fieldnums['firstname']]) ? 'anonymous' : utf8_encode($user[$fieldnums['firstname']])),
                  'lastname' => (empty($user[$fieldnums['lastname']]) ? 'anonymous' : utf8_encode(user[$fieldnums['lastname']])),
In:

Code: Alles auswählen

                $importdata[] = array(
                  'email' => $user[$fieldnums['email']],
                  'firstname' => (empty($user[$fieldnums['firstname']]) ? 'anonymous' : $user[$fieldnums['firstname']]),
                  'lastname' => (empty($user[$fieldnums['lastname']]) ? 'anonymous' : $user[$fieldnums['lastname']]),
Beim export finde ich in der pages/users.inc.php folgendes:

Code: Alles auswählen

  if(!empty($_POST) && !empty($REX['ADDON375']['postget']['newsletter_exportusers']))
  {
    $userdata = rex_a375_export_userlist($REX['ADDON375']['items']);

    header("Cache-Control: public");
    header("Content-Description: File Transfer");
    header('Content-disposition: attachment; filename=multinewsletter_user.csv');
    header("Content-Type: application/csv");
    header("Content-Transfer-Encoding: binary");
    header('Content-Length: '.strlen($userdata));
    print($userdata); 
    exit;
  }
Jedoch wenn ich Content-Transfer-Encoding umstelle, z.b. auf 7bit, 8bit, utf-8 oder quoteable-printable umstelle, passiert rein gar nichts...
selbst wenn ich die Zeile rauslösche wird mir das CSV erstellt...!?
Bin ich am falschen Weg?



Was mir in der Zwischenzeit noch aufgefallen ist:
der Bestätigungslink, der per email verschickt wird, enthält anstelle eines "&" einen "&" string....

Benutzeravatar
alex2911
Beiträge: 567
Registriert: 20. Jul 2005, 04:13
Wohnort: Österreich
Kontaktdaten: Website

23. Jan 2009, 17:01

schau dir mal diese funktion an:
rex_a375_export_userlist()

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

27. Jan 2009, 01:57

alex2911 hat geschrieben:schau dir mal diese funktion an:
rex_a375_export_userlist()
Danke Dir auch für diesen Hinweis.... gehe dem Export momentan aber noch nicht nach - vorher würde ich gerne mal einen Newsletter verschicken können, der fehlerfrei ist.

Leider besteht das & Problem, sowie anscheinend ein Zeichensatz-Problem bei der Anmeldung sowohl als auch beim Newsletter selbst immer noch!

d.h. einerseits wenn man die Daten zur Anmeldung eingegeben hat und alles korrekt ausgefüllt wurde:
Ihnen wurde soeben eine Bestätigungs-E-Mail geschickt - die Anfrage wird erst fertiggestellt, wenn Sie den in der E-Mail enthaltenen Link geklickt haben.

Der Link sieht dann so aus:
http:/blablabla/index.php?article_id=134&key=username%2540domain.net%252CqKFxZM

auf Grund des & klappt das natürlich nicht...

Im Newsletter selbst, verschicke ich ebenfalls Links die, sofern sie nicht als ausdrücklicher Link selbst eingetippt wurden, sondern z.b. als Abfrage aus dem Veranstaltungskalender für die nächsten 5 events stehen, ebenfalls dieses ominöse & beinhalten.

ebenso wird bei der Geschlechtsauswahl das "männlich" mit Umlaut-Fehler (sprich Zeichenwirrwarr) angezeigt...

kdk
Beiträge: 123
Registriert: 19. Dez 2005, 14:36

27. Jan 2009, 10:45

Bis auf den Fehler bei der Installation funktioniert bei mir jetzt alles einwandfrei. Bis auf die Newsletterabmeldung - ich bekomme bei der Abmeldung eine Bestätigungsmail zugeschickt....und abgemeldet ist natürlich gar nichts...

kdk
Beiträge: 123
Registriert: 19. Dez 2005, 14:36

27. Jan 2009, 13:33

So, ich hab das jetzt gefunden. Das Add-on verschickt die gleiche Mail zur An- und Abmeldung.

Nur den automatischen LLink zum ABmelden bekomme ich nicht hin, setze ich ihn mit textile in einen Artikel wird aus:

Code: Alles auswählen

"hier":http://///LINK///
ein:

Code: Alles auswählen

index.php?article_id=9">hier
:roll:

Benutzeravatar
alex2911
Beiträge: 567
Registriert: 20. Jul 2005, 04:13
Wohnort: Österreich
Kontaktdaten: Website

27. Jan 2009, 22:03

versuch mal ein leerzeichen nach dem letzten /

kdk
Beiträge: 123
Registriert: 19. Dez 2005, 14:36

28. Jan 2009, 12:35

Das war leider nicht die Lösung, nachdem ich in der newsletter.inc.php Zeile 189

folgendes:

Code: Alles auswählen

      $content = str_replace( "///NEWSLETTERLINK///",$newsletterlink.'" target="_blank">'.htmlspecialchars(stripslashes($newsletterlink),ENT_QUOTES).'</a>',$content);
durch:

Code: Alles auswählen

$content = str_replace( "///NEWSLETTERLINK///",$newsletterlink,$content);
ersetzt habe, funktioniert es einwandfrei.

Danke für die Mühe.

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

28. Jan 2009, 15:37

alex2911 hat geschrieben:schau dir mal diese funktion an:
rex_a375_export_userlist()
in der Zwischenzeit hab ich mir auch das angesehen:
Meine Lösung:
functions/newsletter.inc.php line 251
einfach

Code: Alles auswählen

      //$lines = utf8_decode($lines);
und schon gings mit den Umlauten...

Trotzdem funktionieren andere Dinge noch nicht.

Benutzeravatar
alex2911
Beiträge: 567
Registriert: 20. Jul 2005, 04:13
Wohnort: Österreich
Kontaktdaten: Website

28. Jan 2009, 20:04

so ist es im leben :lol:
mal im ernst: überleg dir ob du das addon nicht gleich selbst schreibst - bevor du noch tage oder wochen darin investierst.

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

28. Jan 2009, 21:53

alex2911 hat geschrieben:so ist es im leben :lol:
mal im ernst: überleg dir ob du das addon nicht gleich selbst schreibst - bevor du noch tage oder wochen darin investierst.
Einfach gesagt:
Das kann ich nicht :? Bin kein Programmierer...
Dachte mir das der Addonentwickler da mit einsteigt, aber schaun wir mal.

Bis auf ein paar Schönheitsfehler funktioniert's ja ganz gut...

Benutzeravatar
alex2911
Beiträge: 567
Registriert: 20. Jul 2005, 04:13
Wohnort: Österreich
Kontaktdaten: Website

28. Jan 2009, 22:36

hey, dann wirds zeit :)
wenn du nie anfängst, wirst du auch nie zum "programmierer".

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

28. Jan 2009, 23:06

alex2911 hat geschrieben:hey, dann wirds zeit :)
wenn du nie anfängst, wirst du auch nie zum "programmierer".
lol - will das Thema nicht offtopic führen, aber:
Leider Null Zeit - Lernen würde ich es gerne - vor Redaxo hat ich absolut keinen Tau über php usw. jetzt ergeben manche Dinge schon Sinn - für ein Addon reichts aber lange noch nicht...

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

29. Jan 2009, 22:48

So, wieder was ausgebügelt:
Die Umlautfehler (die allem Anschein nach nur bei mir auftauchen) bei der Meldung das eine "Bestätigungs" zugesandt wird bzw. "männl." / "weibl."!

Diese verstecken sich im File:
/include/addons/multinewsletter/files/clang0.lang

Wenn man das Sprach-File nicht in UTF-8 sondern in ANSI abspeichert, ist dieser Fehler behoben ;)

Nächster Bug:
Beim Abo, ist's ohne Auswirkung auf die DB ob man weibl. oder männl. auswählt... - in der DB ist automatisch immer männl. ausgewählt

Maidenaustria
Beiträge: 295
Registriert: 7. Mär 2006, 10:43
Wohnort: Österreich

31. Jan 2009, 00:49

hm...
um das & im Bestätigungslink zur An und Abmeldung wegzubekommen musste ich folgendes tun:

In functions/newsletter.inc.php
Zeile 199 + 200

Code: Alles auswählen

$content = str_replace( "///LINK///",html_entity_decode(stripslashes($link),ENT_QUOTES),$content);

$content = str_replace( "///NEWSLETTERLINK///",html_entity_decode(stripslashes($newsletterlink),ENT_QUOTES),$content);
soweit ich mit testen bin, fällt mir weiter nichts besonderes auf....
Dürfte laufen!

Zurück zu „Allgemeines [R4]“