Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Benutzeravatar
fietstouring
Beiträge: 47
Registriert: 10. Okt 2006, 12:30
Wohnort: Wien
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

21. Jan 2014, 13:35

Hallo!

sehe ich das richtig, dass ich den TVSBlog derzeit nur einsprachig fahren kann? die Blog-Artikel kann ich nur einsprachig eingeben, wie ich gesehen habe, wird in der datenbank aber trotzdem eine clang eingetragen.

Weiters hab ich mich gefragt, ob und wie die Kategorien gerewritet werden können.
zu einem blogartikel komme ich zwar über http://meineseite.de/blogkategorie/blogartikel. was bei mir nicht klappt ist http://meineseite.de/blogkategorie

beste Grüße
Philipp

Benutzeravatar
michaelwandel
Beiträge: 331
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Blogsystem [TvsBlog]

21. Jan 2014, 16:42

Hi,

ja das ist richtig, bisher ist TVSBlog nur einsprachig, die clang ist schon mal die Vorbereitung für Mehrsprachigkeit, bisher aber leider mangels Masse nicht umgesetzt ;-)

auch das Rewriting der Kategorien ist noch ein Stiefkind, wobei ich mich für die kommende Version 1.50, die auch die Kommentarfunktion beinhalten wird, mal daran begebe ;-)

Noch ein wenig Geduld, Gruß, Michael ;-)

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

21. Jan 2014, 16:52

Ich glaube Geduld haben wir alle.

Insbesondere ich bin extrem dankbar für die Entwicklung von TvsBlog. Und das Ding hat eine tolle Entwicklung genommen!

Ralf
- Danke für Redaxo! -
http://www.prenzlweb.de

Benutzeravatar
nuxx
Beiträge: 164
Registriert: 16. Dez 2005, 18:45
Wohnort: Kaputtgart 21

Einträge werden verschluckt

4. Mär 2014, 23:30

Hallo !
Bin gerade auf eine kleine Merkwürdigkeit gestoßen:
Habe einen älteren Eintrag umgeschrieben. Nach dem Abspeichern wird der Artikel weiterhin im Backend angezeigt (online) - aber im Frontend nicht mehr ausgegeben.
Konnte das bei mehreren edits beobachten.
Ich nutze das aktuelle Ausgabemodul.
Im Frontend lasse ich alle Kategorien anzeigen.

R 4.5.0
TVS Blog 1.4.2
SEO42
l.G. nuxx
Halbwissen ist schonmal besser als Vollpfosten!

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

5. Mär 2014, 01:36

Grad vorher an anderer Stelle geschrieben:
Wenn etwas nicht mehr angezeigt wird oder eine leere Seite kommt, deutet das meist auf einen PHP Fehler hin der aber nicht angezeigt wird. Schalt also mal dein Error Reporting an.

Benutzeravatar
seelenenergie
Beiträge: 52
Registriert: 31. Dez 2012, 18:29

Re: Neues einfaches Blogsystem [TvsBlog]

7. Mär 2014, 13:43

Hey Leute,
ich habe auch noch ein kleines Problemchen...

Würde gerne den RSS-Feed des Blog nutzen, der Haken ist nur das die "tvsblog.xml" in dem Ordner "files" gespeichert werden sollte. Nur tut sie das irgendwie nicht...

Wäre für Lösungsansätze sehr dankbar.

Lg
Christian

Benutzeravatar
michaelwandel
Beiträge: 331
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

7. Mär 2014, 14:00

Hi,

der RSS-Feed wird jedesmal bei Erzeugen bzw. Aktualisieren von Artikeln komplett neu erzeugt, sollte eigentlich klappen :-)

Gruß, Michael :-)

Benutzeravatar
nuxx
Beiträge: 164
Registriert: 16. Dez 2005, 18:45
Wohnort: Kaputtgart 21

Re: Neues einfaches Blogsystem [TvsBlog]

20. Apr 2014, 20:24

Hallo Micha,
ich habe TVS Blog auf mehreren Seiten erfolgreich mit Rexseo und seo42 laufen.
Mein neues Projekt wird dieses mal mit dem yrewrite Addon sein. Wird dieses Addon von TVS Blog unterstützt, bzw wäre es einfach anzupassen?

Hat das evtl schon mal jemand umgesetzt ?
l.G Nuxx
Halbwissen ist schonmal besser als Vollpfosten!

Benutzeravatar
michaelwandel
Beiträge: 331
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

21. Apr 2014, 12:55

Hoi,

hab yRewrite leider noch nicht benutzt, wenn es aber die gleichen Klassenmöglichkeiten verwendet wie Rexseo und seo42 dürfte es nicht so aufwändig sein, das auch noch zu integrieren, schaue mir das mal nach den Ferien an ;-)

Gruß, Michael :)

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

21. Apr 2014, 18:21

Hat jemand eigentlich den aktuellen CKEditor schon im Blog zum Laufen bekommen?

Der Codeabschnitt on der articles.inx.php lautet ja

Code: Alles auswählen

} else if(OOAddon::isAvailable('ckeditor')) {
						if ($REX['ADDON']['ckeditor']['settings']['lazy_load']) {
							// lazy load ckeditor files
							echo rex_ckeditor_utils::getHtml();
							$textareaclass = "ckeditor1";
							$textareaid = "ckeditor1";
							$textareastyle = "";
						}
					} else {
						$textareaclass = "";
					}
				?>

				<div class="rex-form-row">
					<p class="rex-form-col-a rex-form-textarea">
						<label for="description">Beschreibung</label>
						<textarea name="description" class="<?php echo $textareaclass; ?>" id="<?php echo $textareaid; ?>" style="<?php echo $textareastyle; ?>"><?php echo htmlspecialchars($description); ?></textarea>
					</p>
				</div>
Ich habe es schon auf ckeditor1 geändert. Aber anders als bei xform läuft das Ding nicht an...
- Danke für Redaxo! -
http://www.prenzlweb.de

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

21. Apr 2014, 20:51

Probiers mal so vielleicht:

Code: Alles auswählen

} else if(OOAddon::isAvailable('ckeditor')) {
                     $textareaclass = "ckeditor";
                     $textareaid = "ckeditor1";
                     $textareastyle = "";
               } else {
                  $textareaclass = "";
               }
            ?>

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

22. Apr 2014, 12:29

Hallo Rudi,

ich bin erstaunt über deine Hilfe. Auf den Punkt. Genau so funktioniert es.
Fließt dann in die nächste Version mit ein.

Gruß und Dank
Ralf
- Danke für Redaxo! -
http://www.prenzlweb.de

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

22. Apr 2014, 13:48

Und nun gibt es mit der aktuellen SEO42 3.3.0 leider ein Problem:

TvsBlog 1.4.2

Code: Alles auswählen

Notice: Undefined variable: lang_id in ////redaxo/include/addons/tvsblog/classes/urlRewrite.inc.php on line 74

Notice: Undefined index: in ////redaxo/include/addons/seo42/classes/class.rexseo_rewrite.inc.php on line 889

Notice: Undefined index: in ////redaxo/include/addons/seo42/classes/class.rexseo_rewrite.inc.php on line 889
In Zeile 74 der urlRewrite.inc.php steht:

Code: Alles auswählen

$pathname = rexseo_appendToPath($pathname, $blog_article_name, $blogArticle_id, $lang_id);
Wahrscheinlich macht hier die Vorbereitung auf die Mehrsprachigkeit Probleme?
- Danke für Redaxo! -
http://www.prenzlweb.de

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

23. Apr 2014, 12:46

In Zeile 74 wird $lang_id genutzt, davor aber nicht gesetzt. In der Variable steht als nix drin. Evtl. muss es $clang heissen? Die gibt es nämlich...

Michi: Wenn du ne neue Version fertig machst, denk vielleicht dran auch die vielen anderen Notices zu fixen die überalle im TvsBlog (und bei Install) auftauchen ;)

Benutzeravatar
michaelwandel
Beiträge: 331
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

6. Mai 2014, 08:43

Mach ich ;-)

Muss endlich mal Zeit finden -.-

Gruß, Michael :)

dominik
Beiträge: 8
Registriert: 12. Jul 2013, 17:14

Re: Neues einfaches Blogsystem [TvsBlog]

7. Mai 2014, 15:37

Hallo liebe TVSBlog-User,

der Blog ist Klasse und hat fast alles was ich brauche. Zwei Dinge hätte ich gerne eingefügt und bevor ich mir da nen Wolf programmiere ... vielleicht hat's ja schon einer gemacht.

1. Eine Tag-Cloud
Hat das schon mal jemand umgesetzt? Eine einfache Tagliste würde eigentlich auch schon reichen.

2. Weiter/Zurück
Ich würde gerne, wenn ich einem Blogeintrag bin, einfach weiter zum nächsten, bzw. vorherigen veröffentlichten Eintrag wechseln. Gibt es dafür eine Lösung.

Freue mich über alle Anregungen.

Grüße
Dominik

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

7. Jan 2015, 17:28

Hallo, ich möchte gerade das Addon (1.4.2) unter PHP 5.3.28-nmm1 und Redaxo 4.6.1 installieren (Redaxo befindet sich in einem Unterordner). Bekomme haufenweise Fehlermeldungen:

Code: Alles auswählen

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/www/htdocs/XXXXX/:/tmp:/usr/bin:/www/htdocs/XXXXX:/bin:/usr/local/bin:/usr/share/php:/dev/urandom) in /www/htdocs/XXXXX/dev_2/redaxo/include/functions/function_rex_generate.inc.php on line 892

Warning: mkdir() [function.mkdir]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/www/htdocs/XXXXX/:/tmp:/usr/bin:/www/htdocs/XXXXX:/bin:/usr/local/bin:/usr/share/php:/dev/urandom) in /www/htdocs/XXXXX/dev_2/redaxo/include/functions/function_rex_generate.inc.php on line 897

Warning: chmod() [function.chmod]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/www/htdocs/XXXXX/:/tmp:/usr/bin:/www/htdocs/XXXXX:/bin:/usr/local/bin:/usr/share/php:/dev/urandom) in /www/htdocs/XXXXX/dev_2/redaxo/include/functions/function_rex_generate.inc.php on line 898

Warning: is_dir() [function.is-dir]: open_basedir restriction in effect. File(/www/) is not within the allowed path(s): (/www/htdocs/XXXXX/:/tmp:/usr/bin:/www/htdocs/XXXXX:/bin:/usr/local/bin:/usr/share/php:/dev/urandom) in /www/htdocs/XXXXX/dev_2/redaxo/include/functions/function_rex_generate.inc.php on line 892

Warning: mkdir() [function.mkdir]: open_basedir restriction in effect. File(/www/) is not within the allowed path(s): (/www/htdocs/XXXXX/:/tmp:/usr/bin:/www/htdocs/XXXXX:/bin:/usr/local/bin:/usr/share/php:/dev/urandom) in /www/htdocs/XXXXX/dev_2/redaxo/include/functions/function_rex_generate.inc.php on line 897
Bin für Hilfe dankbar...

NACHTRAG: Nach Umstellung auf PHP 5.4 Sind die open_basedir Fehler weg. Jedoch folgende:

Code: Alles auswählen

Warning: require_once(/www/htdocs/XXXXX/dev_2/redaxo/include/addons/tvsblog/classes/../../seo42/classes/class.rexseo_rewrite.inc.php): failed to open stream: Datei oder Verzeichnis nicht gefunden in /www/htdocs/XXXXX/dev_2/redaxo/include/addons/tvsblog/classes/urlRewrite.inc.php on line 15

Fatal error: require_once(): Failed opening required '/www/htdocs/XXXXX/dev_2/redaxo/include/addons/tvsblog/classes/../../seo42/classes/class.rexseo_rewrite.inc.php' (include_path='.:/usr/share/php:..') in /www/htdocs/XXXXX/dev_2/redaxo/include/addons/tvsblog/classes/urlRewrite.inc.php on line 15

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

7. Jan 2015, 18:25

Habe in der Datei "addons/tvsblog/classes/urlRewrite.inc.php" in Zeile 15 folgendes geändert:

Code: Alles auswählen

require_once dirname(__FILE__) ."/../../seo42/classes/class.rexseo_rewrite.inc.php";
wird zu:
require_once dirname(__FILE__) ."/../../seo42/classes/class.seo42_rewrite.inc.php";
SEO42 ist in Version 4.1.0 installiert.

EDIT: Installation klappt nun. Jedoch bekommen ich folgende Fehlermeldung wenn ich eine Kategorie erstellen möchte:

Code: Alles auswählen

Fatal error: Call to undefined function rexseo_generate_pathlist() in /www/htdocs/XXXXX/dev_2/redaxo/include/addons/tvsblog/pages/categories.inc.php on line 31
FRAGE: Ist TvsBlog 1.4.2 überhaupt mit SEO42 4.1.0 kompatibel?

Benutzeravatar
CWS
Beiträge: 68
Registriert: 15. Jun 2014, 12:09

Re: Neues einfaches Blogsystem [TvsBlog]

7. Jan 2015, 20:22

Moin, ja er ist kompatibel.
Schicke mir mal ne private Nachricht mit Kontaktdaten, dann lasse ich dir meine umgebaute Version zukommen....

Gruß Christian :-)
Christian Haß - Spirituelle Heilung - - Akademie spirituelles Heilen - - Spirit Online Store - Schwierig sein kann es nur, weil du es so glaubst ;-)

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

9. Jan 2015, 17:32

Wenn die neue Version wirklich vollständig ist, könnte man die doch veröffentlichen...
- Danke für Redaxo! -
http://www.prenzlweb.de

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

Re: Neues einfaches Blogsystem [TvsBlog]

25. Jan 2015, 13:35

ralf.schlott hat geschrieben:Wenn die neue Version wirklich vollständig ist, könnte man die doch veröffentlichen...
Das würde ich unterstützen. Leider gibt seo42 in Verbindung mit tvsblog html-Links in der sitemap aus, die es gar nicht gibt. Zumindest gibt es kein Umleitung darauf durch seo42.
Unter rexseo waren die Artikellinks falsch und der Blog richtig. Jetzt ist es umgekehrt.

Statt domain.de/verzeichnis/blogname.html?post_id=480 erscheint in der sitemap.xml so etwas:
domain.de/unterverzeichnis/blogname/Langer-Titel.htm.html
Dieser Link endet natürlich auf der 404-Seite.

1000...0 Grüße
Daniel
Warum ich hier bin? Meine Frustrationsgrenze wurde schon lange nicht mehr vollständig ausgelotet ... :-)

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

25. Jan 2015, 14:34

Ich kann gerne die Version von Christian (CWS), die ich noch verändert habe zur Verfügung stellen. Ich habe noch ein paar Bugs beseitigt, wenn Redaxo in einem Unterordner läuft. Ich muss das noch mal alles durchegehen und werde diese dann natürlich hier posten! Habe momentan viel zu tun. Ich kann noch nicht genau sagen, wann ich es schaffe...

LG Daniel

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

12. Feb 2015, 17:01

Hier mal meine aktuelle Version inkl. Mehrsprachigkeit.

- URL Ausgabe Korrektur Facebook Metainfos wenn Redaxo im Unterordner
- Mehrsprachigkeit eingefügt (basierend auf Redaxo System Sprachen)
- Blog Artikel werden passend anhand der aktuellen Sprache ($REX['CUR_CLANG']) ausgegeben.
- Hinweis: Wenn Sprachen gelöscht werden, werden auch alle zugehörigen Blog Artikel gelöscht
- Wichtig: Das Ausgabe Modul natürlich auch in alle Sprachen des Blog Artikels (Blog-Artikel-ID) einsetzten.

Dank an ArtStudioDESIGN für das asd_news Addon, welches als Vorlage für die Mehrsprachigkeit diente.

Wie immer, bitte gut testen und Fehler posten! Bei mir läuft das Addon bis jetzt ohne Probleme.

PS: Die Module müssten noch angepasst werden, habe bis jetzt nur "modul_blogausgabe.rex" verändert.
Hinweis: Bei der Installation werden bei mir nach wie vor auch noch keine Bildtypen erstellt.

Getestet mit:
REDAXO: 4.6.1
PHP: 5.3.28
SEO42 4.1.1
Dateianhänge
addon_tvsblog_1.4.2_seo42_Mehrsprachig.zip
TVSBlog Mehrsprachigkeit
(39.53 KiB) 2251-mal heruntergeladen

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

12. Feb 2015, 21:24

Hier noch ein schnelle Tag Coud, sollte alles selbsterkärend sein:
(Ist noch nicht für Mehrsprachigkeit ausgelegt)

Code: Alles auswählen

<?php

	$table_pre = $REX['TABLE_PREFIX'] . $REX['ADDON']['rxid']['tvsblog'];
	$art_table = $table_pre . "_articles";

	echo "<h2>Tags:</h2>";
	$sql = new rex_sql();
	$tags_out = "";
	$tags_einzel = "";
	$sql->setQuery("SELECT * FROM " . $art_table . " WHERE status = 1 ORDER BY id");
	if ($sql->getRows() > 0 )
	{
	for ($i = 1; $i <= $sql->getRows(); $i++) {
	if ($sql->getValue('tags') != "") {
		$tags_einzel .= $sql->getValue('tags');
		if ($i != $sql->getRows()) $tags_einzel .= ",";	
	}
		$sql->next();
	}
		$tags = explode(",", $tags_einzel);

		$tagsCount = (array_count_values($tags));
		
		foreach ($tagsCount as $value => $key) {
			
		// Class Generation	
		if ($key < 5) { $class = "tag-s"; }
		if ($key > 5 && $key < 10) { $class = "tag-m"; }
		if ($key > 10 && $key < 15) { $class = "tag-l"; }
		if ($key > 15 && $key < 20) { $class = "tag-xl"; }
		if ($key > 25) { $class = "tag-xxl"; }	
			
	$mytvsBlogIniFile	= $REX['INCLUDE_PATH'] . "/addons/tvsblog/tvsblog.ini";
	$tvsblogsettings	= parse_ini_file($mytvsBlogIniFile);
	$blogArticle_id		= $tvsblogsettings['blogArticle_id'];
		if (trim($value) != "")
		$tags_out .= '<a class="'.$class.'" data-count="'.$key.'" href="'. rex_getUrl($blogArticle_id,"", array("tag"=>trim($value)), "&") .'">'.trim($value).'</a>';
		}

echo $tags_out;
}
?>
Zuletzt geändert von morfer am 13. Feb 2015, 08:53, insgesamt 1-mal geändert.

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

12. Feb 2015, 23:20

Super! Vielen Dank für deine Arbeit. Hab grad ein Projekt bei dem ich das testen kann.

Gruß Ralf
- Danke für Redaxo! -
http://www.prenzlweb.de

Zurück zu „Allgemeines [R4]“