Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
frood
Beiträge: 226
Registriert: 7. Okt 2008, 15:17

Vorschaubild mediafile xform

22. Dez 2013, 19:38

Moin,

anscheinend hat sich bei der neuesten xform-Version (4.5.1) ein Fehler eingeschlichen, sodass bei einem Dateiupload über das Frontend kein Vorschaubild mehr angezeigt wird.

In der class.xform.mediafile.inc.php stand in älteren Versionen beim label-output noch:

Code: Alles auswählen

<label class="text '.$wc.'" for="'.$this->getFieldId().'" >'.$this->getElement(2).'</label>
In der neuen steht:

Code: Alles auswählen

<label class="text '.$wc.'" for="'.$this->getFieldId().'" >'.$this->getLabel().'</label>
Es wird also der ursprüngliche Label ausgegeben und nicht der um das Vorschaubild ergänzte.

Wenn man wieder die alte Zeile nimmt gehts wieder.
Hat noch jemand dieses Problem gehabt oder habe ich beim Update irgendwas zerschossen?

Gruss, Frood

Zurück zu „Allgemeines [R4]“