janhdb
Beiträge: 1
Registriert: 13. Mär 2016, 22:28

Nach Umzug werden keine Bilder mehr angezeigt.

14. Mär 2016, 16:35

Hallo zusammen,

habe schon nach dem Problem gegoogelt aber bis jetzt leider keine Lösung gefunden.

Wir sind mit einer Redaxo Webseite welche wir übernommen haben auf einen anderen Server umgezogen.
Datenbank und URL habe ich geändert. Leider werden auf dem neuen Webserver keine Bilder mehr in den Modulen angezeigt.

"img/content-small/2016_02_2781.jpg"

Leider existiert dieser Ordner nicht. Sondern alle Bilder befinden sich im Files Ordner.

In den Einstellungen bei Modulen ist folgendes unter Bildern eingetragen:

Code: Alles auswählen

<?php

do {

$heading = '';
if(REX_IS_VALUE[1])
{
  $heading = 'REX_VALUE[1]';
}

$heading = trim($heading);

if($REX['REDAXO'])
{
  echo $heading;
  if(strlen(trim('REX_MEDIALIST[1]')))
  {
    foreach(explode(',', 'REX_MEDIALIST[1]') as $img)
    {
      echo '<img src="../index.php?rex_img_type=rex_mediapool_preview&rex_img_file='.urlencode($img).'" alt="" />';
    }
  }
  else
  {
    echo '<em>Keine Bilder angegeben.</em>';
  }
  
  break;
}

$main = '';
if(strlen(trim('REX_MEDIALIST[1]')))
{
  foreach(explode(',', 'REX_MEDIALIST[1]') as $img)
  {
    $main .= '<img src="img/'.(strlen($heading) ? 'content-small' : 'content-big').'/'.urlencode($img).'" alt="" />';
  }
}
?><div<?php echo REX_IS_VALUE[10] ? ' id="'.strtolower(rex_parse_article_name(strip_tags('REX_VALUE[10]'))).'"' : ''; ?> class="box<?php
echo REX_IS_VALUE[1] ? ' REX_VALUE[3]' : '';
echo REX_IS_VALUE[10] ? ' nav-box' : '';
?>">
  <?php if(strlen($heading)) echo '<div class="heading"><span>'.$heading.'</span></div>'; ?>
  <div class="main"><?php echo $main; ?></div>
</div><?php

} while(false);
?>

Kann mir einer dabei helfen?

Ingo
Beiträge: 782
Registriert: 24. Jun 2010, 00:34

Re: Nach Umzug werden keine Bilder mehr angezeigt.

14. Mär 2016, 20:51

Vergleich doch mal die alte mit der neuen .htaccess

Zurück zu „Installation [R4]“