Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
elsethos
Beiträge: 27
Registriert: 17. Okt 2008, 07:55

yform Update auf 2.3-b4 oder 2.3-b5 funktioniert nicht

9. Jan 2018, 07:56

Hallo,

ich habe gerade REDAXO auf die neueste Version geupdated und wollte anschließend die Addons updaten. Hat auch alles geklappt, bis auf yform.
Kann mir jemand helfen?


Fehlermeldung:

Code: Alles auswählen

AddOn "yform" konnte aus folgendem Grund nicht aktualisiert werden:
SQL error: Error while executing statement "ALTER TABLE `rex_yform_history` CHANGE `id` `id` int(10) unsigned NOT NULL auto_increment;"! SQLSTATE[HY000]: General error: 1833 Cannot change column 'id': used in a foreign key constraint 'rex_yform_history_field_ibfk_1' of table 'dbXXXXXX.rex_yform_history_field'

System:
REDAXO 5.5.1
PHP 7.0.20

Benutzeravatar
Oliver.Kreischer
Beiträge: 2509
Registriert: 17. Dez 2004, 00:03
Wohnort: Velbert - LA
Kontaktdaten: Website

Re: yform Update auf 2.3-b4 oder 2.3-b5 funktioniert nicht

9. Jan 2018, 10:31

Hi,


das Problem hatte ich gestern auch und Gregor hat mir die Lösung genannt :-))

Du installierst das AddOn "Adminer" und löschst in der Tabelle "rex_yform_history_field" den Fremdschlüssel.
Danach sollte das Update wie gewünscht funktionieren.

LG
Oliver
> Friends Of REDAXO Gemeinsame REDAXO-Entwicklung!
> REDAXO Agenturen. Eintragen erwünscht!
> Komm in den Slack Channel Es lohnt sich!

elsethos
Beiträge: 27
Registriert: 17. Okt 2008, 07:55

Re: yform Update auf 2.3-b4 oder 2.3-b5 funktioniert nicht

9. Jan 2018, 11:44

Hallo,

danke für die Antwort. Hat geholfen. :wink:

Zurück zu „Installation [R5]“