Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
sandmaus
Beiträge: 569
Registriert: 27. Apr 2006, 11:26
Wohnort: Dresden
Kontaktdaten: Website

Ausgabeproblem nach einlesen Medienkategorie

18. Jul 2017, 13:18

Hallo Ihr

ich habe via Eingabemodul eine Medienkategorie ausgewählt.

Im AusgabeModul möchte ich die Bilder dieser Medienkategorie anzeigen.

Code: Alles auswählen

<?php
$category = rex_media_category::get(REX_VALUE[1]);
if ($category) {
unset($rxmodule);
$rxmodule  = $category->getMedia();
foreach ($rxmodule as $file) {
$bild = rex_media::get($file);
echo $bild->getFileName();
}
} 
?>
Ich erhalte immer eine leere Ausgabe. Würde mich über Hilfe freuen, wahrscheinlich habe ich eine Klasse vergessen und bekomme es nicht hin.

Danke für Eure Hilfe
Grüße sandmaus

sandmaus
Beiträge: 569
Registriert: 27. Apr 2006, 11:26
Wohnort: Dresden
Kontaktdaten: Website

Re: Ausgabeproblem nach einlesen Medienkategorie

18. Jul 2017, 18:48

gelöst :)

Code: Alles auswählen

$medias = rex_media_category::get(1)->getMedia();
hat gefehlt

Danke

Zurück zu „Module/Aktionen [R5]“