Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/

Die Suche ergab 107 Treffer

Zur erweiterten Suche

von Include
7. Jan 2016, 15:27
Forum: Allgemeines [R4]
Thema: Sprachenwechsel: Nur bestimmte sprachen, ausgeben
Antworten: 2
Zugriffe: 3074

Re: Sprachenwechsel: Nur bestimmte sprachen, ausgeben

Danke Ingo!
Das hat geklappt! :wink:
von Include
7. Jan 2016, 11:39
Forum: Allgemeines [R4]
Thema: Sprachenwechsel: Nur bestimmte sprachen, ausgeben
Antworten: 2
Zugriffe: 3074

Sprachenwechsel: Nur bestimmte sprachen, ausgeben

Hallo Forum, ich habe mich mit dem Thema REDAXO und php schon lange nicht mehr beschäftigt. Nun habe ein kleines Problem. Bei einer alten Seite verwende ich ein Sprachen Wechsel Template. Nun habe ich drei Sprachen angelegt de/en/es. Da ich de/en bereits fertig übersetz habe, möchte ich nun diese be...
von Include
6. Feb 2015, 22:26
Forum: Allgemeines [R4]
Thema: CKEditor wandelt Tags in HTML-Entities um :-(
Antworten: 11
Zugriffe: 4043

Re: CKEditor wandelt Tags in HTML-Entities um :-(

RexDude hat geschrieben:Hä? Wozu brauchst du jetzt Textile?
Nee, hast recht. Zunächst hatte ich textile verwendet.
Mache ich jetzt aber doch ohne.

Code: Alles auswählen

if ("REX_IS_VALUE[1]")
{
print '<div>'.					
$input =<<< EOT
REX_HTML_VALUE[1]
EOT;
$input
.'</div>';
}
von Include
6. Feb 2015, 22:13
Forum: Allgemeines [R4]
Thema: CKEditor wandelt Tags in HTML-Entities um :-(
Antworten: 11
Zugriffe: 4043

Re: CKEditor wandelt Tags in HTML-Entities um :-(

Ich habe es nun hinbekommen: 1. Textile Addon aktiviert if ("REX_IS_VALUE[1]"){ print '<div>'; $input =<<< EOT REX_HTML_VALUE[1] EOT; $textile = new Textile; $text = $textile->TextileThis($input); print $text; print '</div>'; } Man kann den Code natürlich auch noch etwas eleganter schreiben aber sin...
von Include
6. Feb 2015, 11:19
Forum: Allgemeines [R4]
Thema: CKEditor wandelt Tags in HTML-Entities um :-(
Antworten: 11
Zugriffe: 4043

Re: CKEditor wandelt Tags in HTML-Entities um :-(

Warum gibst du den <h3> ein? Ist ein Wisiwig Editor nicht dazu da nicht Code eingeben zu müssen sondern direkt per Knopfdruck die Sachen die man braucht hinzuzufügen? Gibst du übrigens dein <h3> über die Quellcodeansicht ein, wird nix escaped. Nein, natürlich schreibe ich im Editor nicht <h3> aber ...
von Include
5. Feb 2015, 21:07
Forum: Allgemeines [R4]
Thema: CKEditor wandelt Tags in HTML-Entities um :-(
Antworten: 11
Zugriffe: 4043

Re: CKEditor wandelt Tags in HTML-Entities um :-(

Hi Sysix, das sah erst mal gut aus. Aber in der Umsetzung mache ich scheinbar noch irgendwas falsch. Eingabe: <textarea id="ckeditor1" name="VALUE[1]" style="display: none;">REX_VALUE[1]</textarea> Ausgabe: ... if ( "REX_MEDIA[1]"!=""){ print '<li><img src="'.$REX['HTDOCS_PATH'].'files/REX_FILE[1]" ...
von Include
5. Feb 2015, 17:26
Forum: Allgemeines [R4]
Thema: CKEditor wandelt Tags in HTML-Entities um :-(
Antworten: 11
Zugriffe: 4043

CKEditor wandelt Tags in HTML-Entities um :-(

Hallo, ich versuche mich gerade mit dem CKEditor und habe das Problem das die html Tags die ich im Backend über die Eingabe im Editor erzeugt habe im Frontend als HTML-Entities ausgegeben werden.

Aus wird in der Modulausgabe <h3>

Wie kann ich das abstellen?

Vielleicht weis jemand Rat?
Danke
von Include
30. Sep 2011, 17:34
Forum: Allgemeines [R4]
Thema: nur inhalte bestimmter module auslesen?
Antworten: 6
Zugriffe: 2594

Re: nur inhalte bestimmter module auslesen?

Mit dem unten stehenden Eingabemodul habe ich folgende 3 Werte in dieser Reihenfolge in einen Artikel eingegeben. (von oben nach unten) 120 30 90 Simple Eingabe: <strong>Testwert</strong> <select name="VALUE[1]" class="inp100"> <?php foreach (array("0","10","30","50","70","90","120","140") as $value...
von Include
30. Sep 2011, 17:12
Forum: Allgemeines [R4]
Thema: nur inhalte bestimmter module auslesen?
Antworten: 6
Zugriffe: 2594

Re: nur inhalte bestimmter module auslesen?

Markus.Staab hat geschrieben:Hi,
Hast du alle werte in einem block oder in mehreren ...?
Wie sieht dein code aus?
Hmmm, hab mehrere Blöcke.
Den Code poste ich später. Bin gerade nicht an der richtigen Maschine.
;-)
von Include
30. Sep 2011, 11:20
Forum: Allgemeines [R4]
Thema: nur inhalte bestimmter module auslesen?
Antworten: 6
Zugriffe: 2594

Re: nur inhalte bestimmter module auslesen?

Ah, schon mal ein guter Tip. Aber in welcher Reihenfolge werden eigentlich die Werte ausgegeben. Sie entsprechen nicht der Reihenfolge im Artikel. Wenn ich dieses Beispiel teste: http://www.redaxo.org/de/doku/object-oriented-framework/?mid=41 In meinem Testartikel stehen die Werte nacheinander in de...
von Include
29. Sep 2011, 21:26
Forum: Allgemeines [R4]
Thema: nur inhalte bestimmter module auslesen?
Antworten: 6
Zugriffe: 2594

nur inhalte bestimmter module auslesen?

Hiho, ich würde gerne ein Teasermodul bauen das alle bestimmte Inhalte einer Kategorie ausliest. Mit "bestimmte" meine ich das erste Bild eines Artikels und einen Abstract des Textes einer Seite. Jede Seite beginnt im ersten Modul mit einem Bild. Danach kommen x weitere Bilder und erst dann das Modu...
von Include
20. Sep 2011, 21:00
Forum: Allgemeines [R4]
Thema: notfound ohne css
Antworten: 3
Zugriffe: 1639

Re: notfound ohne css

Base href war ein guter Tipp! Vielen Dank! Nun sieht die Seite korrekt aus, nur die in den Settings eingertragene notfound-Seite wird immer noch nicht angezeigt wenn ich eine beliebige Seite aufrufe die nicht existiert. Es funktioniert nur wenn ich innerhalb gewisser Regeln mit der Url bleibe die ic...
von Include
18. Sep 2011, 22:23
Forum: Allgemeines [R4]
Thema: notfound ohne css
Antworten: 3
Zugriffe: 1639

notfound ohne css

Hallo, ich habe ein Problem bei dem ich null weis woran es liegt: Ich kann unter System/Einstellungen einen Notfound-Artikel definieren, angezeigt wird aber immer nur der Startartikel. Und wenn ich eine beliebige url eingebe die definitiv nicht existiert bleibt diese in der Adressleiste stehen aber ...
von Include
7. Sep 2011, 20:59
Forum: Allgemeines [R4]
Thema: [erledigt] Reihenfolge von REX_MEDIALIST_BUTTON random, wie?
Antworten: 4
Zugriffe: 2409

Re: [erledigt] Reihenfolge von REX_MEDIALIST_BUTTON random,

Ich glaube ich habe daraus dieses Modul gebaut: Ist ja schon so lange her. In meinem Beispiel werden einfach die durch Komma getrennten Werte wieder zerpflückt und als Abstand verwendet. Dann habe ich als Zusatz noch jedes Bild automatisch mit einem Link versehen. Die Url dazu kommt aus einem zusätz...
von Include
1. Jul 2011, 19:13
Forum: Allgemeines [R4]
Thema: [solved] einfachste Modulaktion funktioniert nicht!
Antworten: 4
Zugriffe: 2076

Re: einfachste Modulaktion funktioniert nicht!

Uh, war einfach zu unaufmerksam.
Jetzt gehts! Habe das Prinzip nun verstanden.
:D
1000 dank!!
von Include
1. Jul 2011, 16:46
Forum: Allgemeines [R4]
Thema: [solved] einfachste Modulaktion funktioniert nicht!
Antworten: 4
Zugriffe: 2076

Re: Simple Modulaktion funktioniert nicht!

siehe hier in schick :O) http://www.code.klassentreffen-seelow-92.de/diff+ADDON-46-0.htm?diff=30 Cheffchen Oh, wirklich schick! Klappt aber leider noch immer nicht. ich hab jetzt mit festen werten versucht und das geht auch nicht. ... $width = 200; $height = 200; ... Abgesehen davon geht ja auch de...
von Include
1. Jul 2011, 12:50
Forum: Allgemeines [R4]
Thema: Artikelweiterleitung
Antworten: 2
Zugriffe: 1601

Re: Artikelweiterleitung

Hi, wie sieht den deine Artikelweiterleitung in der Ein/Ausgabe aus?
von Include
1. Jul 2011, 12:48
Forum: Allgemeines [R4]
Thema: [solved] einfachste Modulaktion funktioniert nicht!
Antworten: 4
Zugriffe: 2076

[solved] einfachste Modulaktion funktioniert nicht!

Hallo Leute, ich teste gerade die Aktionen zu den Modulen. Aber irgendwie bekomme ich das nicht hin. Hab glaube ich etwas falsch verstanden... Ich habe zum Test ein einfaches Modul mit dem ein Bild aus dem Medienpool eingefügt wird. Nun möchte ich über einen Presave-Event zusätzliche Informationen (...
von Include
19. Jun 2011, 21:06
Forum: Allgemeines [R4]
Thema: [erledigt] Wie Seitentitel Anpassen
Antworten: 2
Zugriffe: 1922

Re: Wie Seitentitel Anpassen

Alternativ könnte man hier noch den Namen der SubKategorie ausgeben lassen...
Super, das ist was ich nicht gesucht hab!

Muchas gracias
:-)
von Include
18. Jun 2011, 23:30
Forum: Allgemeines [R4]
Thema: [erledigt] Wie Seitentitel Anpassen
Antworten: 2
Zugriffe: 1922

[erledigt] Wie Seitentitel Anpassen

Hallo, weis jemand wie ich eigentlich dem Seitentitel zusätzlich neben der aktuellen Navigationsebene den Namen der übergeordneten Kategorie mitgebe? <title><?php print $REX['SERVERNAME'].' | '.htmlspecialchars($this->getValue("name")); ?></title> Also: SERVERNAME KATEGORIE SEITENTITEL Vielen Dank! ...
von Include
20. Mai 2011, 20:27
Forum: Allgemeines [R4]
Thema: Einsteigerfrage / neue Artikel mit vorbelegten Modulen?
Antworten: 7
Zugriffe: 2154

Re: Einsteigerfrage / neue Artikel mit vorbelegten Modulen?

ich wüsste nicht wie man das machen kann. als workaround könntest du ja einfach eine musterseite pro Kategorie ablegen auf der du schon die Module angelegt hast. Diese Seite könnte Mann einfach auf offline stellen und die Seite dann nur duplizieren wenn man einen neuen Artikel braucht.

grüße include
von Include
20. Mai 2011, 13:55
Forum: Allgemeines [R4]
Thema: mandantenfähigkeit
Antworten: 0
Zugriffe: 971

mandantenfähigkeit

Hallo, wie sieht es eigentlich mit Redaxo und Mandantenfähigkeit aus? Wäre doch toll, wenn man bei der Installation eine Masterinstanz anlegt und dann zusätzlich weitere Datenbank-Kinder anlegen könnte die alle unterschiedliche Seiten verwalten. Gibt es da schon Lösungen oder ist das ggf. geplant? G...
von Include
16. Mai 2011, 14:12
Forum: Allgemeines [R4]
Thema: wie daten aus redaxo als plain txt oder templ. ausgeben?
Antworten: 3
Zugriffe: 1200

Re: wie daten aus redaxo als plain txt oder templ. ausgeben?

ok, danke!!! ich seh mal zu ob ich es einfach via modul rein schreibe.
von Include
16. Mai 2011, 10:50
Forum: Allgemeines [R4]
Thema: wie daten aus redaxo als plain txt oder templ. ausgeben?
Antworten: 3
Zugriffe: 1200

wie daten aus redaxo als plain txt oder templ. ausgeben?

Hallo, um Daten bereitzustellen die dann wiederum via JavaScript weiterverarbeitet werden sollen, suche ich nach einer Möglichkeit Inhalte aus Redaxo in eine Textdatei zu schreiben oder alternativ einfach über eine URL abrufen zu können. Ich hatte daran gedacht zunächst ein Modul zu erstellen das ei...
von Include
13. Mai 2011, 10:38
Forum: Allgemeines [R4]
Thema: [Erledigt] wie schließt man startartikel bei abfrage aus?
Antworten: 8
Zugriffe: 3115

Re: wie schließt man startartikel bei abfrage aus?

So? Grüße Oliver Oh Nein, wie unangenehm! :oops: Ich hatte es schon richtig gemacht. Es wurde nur deswegen nichts ausgegeben, weil wegen falsch gesetzten css klassen weisser Text auf weissem background augegeben wurde. Deswegen hab ich es nicht gesehen. Jetzt alle mal bitte lachen. Oder weinen geht...

Zur erweiterten Suche