Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

25. Okt 2016, 23:02

Hi sueshi,

deine Gruppe ist leer. Der Fehler wird hier behoben: https://github.com/raum2projekt/multine ... er.inc.php

Wegen dem Fehler mit dem ' habe ich endlich einen Server gefunden, auf dem ich den Fehler nachvollziehen kann: 1&1. Bei meinen allen anderen Servern konnte ich den Fehler mit dem ' nicht nachvollziehen. Hier die Fehler bereinigte Version:
https://github.com/raum2projekt/multine ... er.inc.php

Außerdem ist im Anmeldemodul (Ausgabe) ein Fehler:
https://github.com/raum2projekt/multine ... ut.inc.php

Könntest du mir bitte folgendes nach hochladen der Änderungen testen:
- Anmeldung mit einem Namen mit ', z.B. O'Reilley. Erscheint der Name nach Anmeldung korrekt in der User Liste?
- Kannst du einen Newsletter mit dem gerade angelegten User vollständig versenden?
- Kannst du einen Newsletter an eine Gruppe ohne Nutzer versenden?

Vielen Dank im Voraus!

Liebe Grüße,

Tobi

missmissr
Beiträge: 175
Registriert: 9. Mär 2008, 18:36

Wonach User sortiert: Multinewsletter Addon Feedback / Bugfi

18. Nov 2016, 14:38

Hi Multinewsletter User,

bisher hat Multinewsletter super gearbeitet und heute hat sich irgendwie der Versand aufgehängt. Es wären noch 75 Newsletters zu versenden gewesen.

Meine Frage: Nach welchem Kriterium werden beim Versand die User sortiert? Damit ich herausfinden kann, welche 75 Adressen gefehlt haben. Im Archiv sehe ich, dass an 931 verschickt wurde.

Danke für Hilfe,
missmissr.

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 16:53

Hi missmissr,

den Fehler hat mir vor kurzem ein anderer User gemeldet. Welche MultiNewsletter Version verwendest du? Bei dem anderen User war beim Namen des Users ein ' drin (O'Reilley). Das hat dann den Versand aufgehängt. Wie ist das bei dir?

Liebe Grüße,

Tobias

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 17:37

Warum kommen reihenweise Fehlermeldungen mit "Fehler beim Versand an.... bitte prüfen Sie die Benutzerdaten ..."
Es sind keine unerlaubten Zeichen in den Mailadressen, hundertmal nachgeprüft. Wo werden die Mailadressen genau gecheckt?

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 17:39

Noch eine kleine Anregung hätte ich: Früher stand im Archiv immer, an wie viele Adressen der Newsletter gesandt wurde. Könnte man das wieder einfügen? Das war für die Kontrolle immer sehr praktisch ...

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 18:25

sueshi hat geschrieben:Warum kommen reihenweise Fehlermeldungen mit "Fehler beim Versand an.... bitte prüfen Sie die Benutzerdaten ..."
Es sind keine unerlaubten Zeichen in den Mailadressen, hundertmal nachgeprüft. Wo werden die Mailadressen genau gecheckt?
Hi Sueshi,

kannst du mir per PM ein paar der Adressen mailen? Oder darf ich mal auf die DB schauen? So Pauschal kann ich nicht sagen wie das Zustande kommt.

Liebe Grüße,

Tobi

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 18:31

sueshi hat geschrieben:Noch eine kleine Anregung hätte ich: Früher stand im Archiv immer, an wie viele Adressen der Newsletter gesandt wurde. Könnte man das wieder einfügen? Das war für die Kontrolle immer sehr praktisch ...
Hi sueshi,

Kannst du mal schauen ob die neue Version der Datei https://github.com/raum2projekt/multine ... ve.inc.php deine Wünsche erfüllt? Bitte gib mir Bescheid.

Liebe Grüße,

Tobi

missmissr
Beiträge: 175
Registriert: 9. Mär 2008, 18:36

Antwort auf Mailabbruch: Multinewsletter Addon Feedback / Bu

18. Nov 2016, 19:03

Hi Tobias,

ich habe die MultiNewsletter 2.1.1. Bisher hat das echt brav gearbeitet. Das mit den Sonderzeichen und Fehlern in den Mailadressen ist mir auch schon einmal passiert, das weiß ich normal. Damals waren Leerstellen in den Mailadressen weil die in der Datenbank des Unternehmens drin waren und ich die Adressen kopiert hatte. Seit dem kontrolliere ich alle Mailsaddis immer, ich schaue noch einmal, ob mir was auffällt. Aber ich habe nicht herausgefunden, wonach der Versand die Reihenfolge der Mailadressen sortiert hat weil nur so könnte ich doch die fehlenden 75 herausfinden. Kann es was damit zu tun haben, dass es diesmal das erstemal über 1000 sind? Ne, oder?

Danke für Hilfe,
missmissr.

Tobias Krais hat geschrieben:Hi missmissr,

den Fehler hat mir vor kurzem ein anderer User gemeldet. Welche MultiNewsletter Version verwendest du? Bei dem anderen User war beim Namen des Users ein ' drin (O'Reilley). Das hat dann den Versand aufgehängt. Wie ist das bei dir?

Liebe Grüße,

Tobias

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

18. Nov 2016, 19:18

missmissr hat geschrieben:Hi Tobias,

ich habe die MultiNewsletter 2.1.1. Bisher hat das echt brav gearbeitet. Das mit den Sonderzeichen und Fehlern in den Mailadressen ist mir auch schon einmal passiert, das weiß ich normal. Damals waren Leerstellen in den Mailadressen weil die in der Datenbank des Unternehmens drin waren und ich die Adressen kopiert hatte. Seit dem kontrolliere ich alle Mailsaddis immer, ich schaue noch einmal, ob mir was auffällt. Aber ich habe nicht herausgefunden, wonach der Versand die Reihenfolge der Mailadressen sortiert hat weil nur so könnte ich doch die fehlenden 75 herausfinden. Kann es was damit zu tun haben, dass es diesmal das erstemal über 1000 sind? Ne, oder?

Danke für Hilfe,
missmissr.
Hi missmissr,

nein, mit den 1000 hat es nichts zu tun. Bitte mach ein Update auf die aktuelle Version (einfach per Installer Addon). Dann sollte dein Fehler weg sein.

Liebe Grüße,

Tobias

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 19:25

Funktioniert, nur die Übersetzung fehlte noch, habe "multinewsletter_archive_recipients_count = Anzahl" der lang-Datei hinzugefügt.
Danke!!!

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 19:30

Wofür braucht´s eigentlich in der DB die send_archive_id - die bleibt bei mir immer 0? Das wäre nämlich echt super, wenn die bei jedem Versand irgendeinen Wert erhielte. Damit könnte man in der Datenbank die nicht zugestellten ausfiltern.

lg,sue

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 20:49

sueshi hat geschrieben:Funktioniert, nur die Übersetzung fehlte noch, habe "multinewsletter_archive_recipients_count = Anzahl" der lang-Datei hinzugefügt.
Danke!!!
Hi sueshi,

oh, die hatte ich im repository auch geändert und dir nicht gesagt. Sorry.

Super, dass es klappt. Danke fürs Testen.

Liebe Grüße,

Tobi

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

18. Nov 2016, 20:50

sueshi hat geschrieben:Wofür braucht´s eigentlich in der DB die send_archive_id - die bleibt bei mir immer 0? Das wäre nämlich echt super, wenn die bei jedem Versand irgendeinen Wert erhielte. Damit könnte man in der Datenbank die nicht zugestellten ausfiltern.

lg,sue
Hi sue,

wenn der Newsletter vorbereitet wird steht hier die Archiv ID drin. Sobald der User den Newsletter erhalten hat steht wieder null drin. So tracke ich, bei wem der Versand noch aussteht.

Liebe Grüße,

Tobi

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

19. Nov 2016, 14:34

Das ist natürlich eine gute Idee. Aber anscheinend macht es bei mir auch die 0, wenn nach dem Sendevorgang die Fehlermeldungen kommen. Das Problem tritt nur auf, wenn man mehr versenden will, als der Server zulässt. Dann kommen die (ev. irreführenden) Fehlermeldungen zu jeder einzelnen Mailadresse. Und in der DB sind trotzdem alle der Gruppe auf 0 gesetzt.
Noch eine Frage: Wo werden die Einstellungen (z.B. Serverlimits) gespeichert? In der config.inc.php leider nicht. Da waren immer noch die gleichen wie zum Zeitpunkt der Installation ...

lg,sue

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

19. Nov 2016, 15:03

sueshi hat geschrieben:Das ist natürlich eine gute Idee. Aber anscheinend macht es bei mir auch die 0, wenn nach dem Sendevorgang die Fehlermeldungen kommen. Das Problem tritt nur auf, wenn man mehr versenden will, als der Server zulässt. Dann kommen die (ev. irreführenden) Fehlermeldungen zu jeder einzelnen Mailadresse. Und in der DB sind trotzdem alle der Gruppe auf 0 gesetzt.
Noch eine Frage: Wo werden die Einstellungen (z.B. Serverlimits) gespeichert? In der config.inc.php leider nicht. Da waren immer noch die gleichen wie zum Zeitpunkt der Installation ...

lg,sue
Hi Sue,

Serverlimits werden unter redaxo/include/data/addons/multinewsletter/settings.inc.php gespeichert. In deinem Fall würde ich beim Hoster die Limits erfragen und dann die Einstellungen anpassen. Welchen Hoster nutzt du?

Achte auch auf die Einstellungen im PHPMailer Addon. Je nach Hoster sind die Serverlimits bei mail/sendmail anders als bei SMTP. SMTP hat oft gar keine Limits.

Das wäre interessant zu wissen, ob es an den Limits liegt. Dann müsste man hier eine Fehlermeldung einbauen.

Liebe Grüße,

Tobi

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

20. Nov 2016, 14:04

Die Einstellungen stehen schon in config.inc.php, eine eigene settings.inc-php gibt es nicht. Aber wenn ich im Backend Änderungen vornehme, werden sie in der config.inc.php einfach nicht gespeichert. Ich muss das max_mails z.B. in der Datei ändern und per FTP hochladen, sonst wirkt sich da nichts aus, obwohl "Einstellungen wurden aktualisiert" steht ... Die Fehlermeldungen werden definitiv durch das Überschreiten des Serverlimits erzeugt, beim letzten Versand habe ich das Limit 50 in der config.inc.php eingetragen, und es kamen keine Fehlermeldungen, weil nach 50 Mails gestoppt wurde. Theoretisch ginge es nach einer Stunde dann erst weiter mit den nächsten 50.

Hoster ist übrigens webagentur.at, keiner von den ganz billigen...

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Multinewsletter Addon Feedback / Bugfix

20. Nov 2016, 14:30

sueshi hat geschrieben:Die Einstellungen stehen schon in config.inc.php, eine eigene settings.inc-php gibt es nicht. Aber wenn ich im Backend Änderungen vornehme, werden sie in der config.inc.php einfach nicht gespeichert. Ich muss das max_mails z.B. in der Datei ändern und per FTP hochladen, sonst wirkt sich da nichts aus, obwohl "Einstellungen wurden aktualisiert" steht ... Die Fehlermeldungen werden definitiv durch das Überschreiten des Serverlimits erzeugt, beim letzten Versand habe ich das Limit 50 in der config.inc.php eingetragen, und es kamen keine Fehlermeldungen, weil nach 50 Mails gestoppt wurde. Theoretisch ginge es nach einer Stunde dann erst weiter mit den nächsten 50.

Hoster ist übrigens webagentur.at, keiner von den ganz billigen...
Hi Sueshi,

webagentur.at hat einen erstklassigen Support. Da würde ich mal hinschreiben. In der config.inc.php stehen nur die vordefinierten Werte drin. Existiert bei dir das Verzeichnis /redaxo/include/data/addons/multinewsletter/. Falls nicht, erstelle es doch bitte manuell und eventuell auch die Datei settings.inc.php in dem Verzeichnis. Dann liegt ein Rechteproblem vor.

Hilft dir das weiter?

Liebe Grüße,

Tobi

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

20. Nov 2016, 16:39

Oh, danke, das habe ich gefunden. Ich bin noch gewöhnt, dass zugehörige Daten unter files/addons/ stehen...

missmissr
Beiträge: 175
Registriert: 9. Mär 2008, 18:36

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 09:49

Tobias Krais hat geschrieben:
missmissr hat geschrieben:Hi Tobias,

Hi missmissr,

nein, mit den 1000 hat es nichts zu tun. Bitte mach ein Update auf die aktuelle Version (einfach per Installer Addon). Dann sollte dein Fehler weg sein.

Liebe Grüße,

Tobias
HI Tobias,

kann ich das Updaten risikolos machen, wenn ich im Moment Redaxo 4.6.1 betreibe? Nicht. dass dann was insgesamt hakt?

Danke für Hilfe,
missmissr.

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 10:01

missmissr hat geschrieben: kann ich das Updaten risikolos machen, wenn ich im Moment Redaxo 4.6.1 betreibe? Nicht. dass dann was insgesamt hakt?
Hi missmissr,

ja. Wenn du es über den Installer machst wird die Datenbank automatisch aktualisiert und dann geht alles risikolos. Ich habe gerade eine neue Version veröffentlicht die sich nochmals dem Fehler von dir widmet.

Liebe Grüße,

Tobias

missmissr
Beiträge: 175
Registriert: 9. Mär 2008, 18:36

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 16:41

Tobias Krais hat geschrieben:
missmissr hat geschrieben: Hi missmissr,

ja. Wenn du es über den Installer machst wird die Datenbank automatisch aktualisiert und dann geht alles risikolos. Ich habe gerade eine neue Version veröffentlicht die sich nochmals dem Fehler von dir widmet.

Liebe Grüße,

Tobias
Hi Tobias,

Danke für die schnelle Hilfe, ich habe das Update auf 2.2.6 problemlos machen können und ein Test, dass an abgemeldete E-Mail-Adressen nicht!!! mehr gemailt wird (das war nämlich außerdem auch noch der Fall) hat funktioniert. Komplettmail an meine 1007 Adressen kann ich erst nächsten Monat beim nächsten Newsletter wirklich testen.

Eine Frage noch zu den E-Mail-Adressen Formaten: Im Vor- und Familienname dürfen aber schon Umlaute wie ü oder so sein? Oder kann das auch problematisch sein?

Gibt es jetzt noch eine Möglichkeit, wie ich herausfinden kann, welche 75 User von den über 1007 den letzten Newsletter nicht erhalten haben? Hast du da eine Idee? Direkt in der Datenbank oder so? Ich sehe im Archiv ja jetzt schön, dass an 932 User verschickt wurde und mein Problem ist, dass ich die 75 nicht beschickten nicht erkennen kann.

Danke für Hilfe,
missmissr.

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 18:21

Hi missmissr,
missmissr hat geschrieben:Danke für die schnelle Hilfe, ich habe das Update auf 2.2.6 problemlos machen können und ein Test, dass an abgemeldete E-Mail-Adressen nicht!!! mehr gemailt wird (das war nämlich außerdem auch noch der Fall) hat funktioniert. Komplettmail an meine 1007 Adressen kann ich erst nächsten Monat beim nächsten Newsletter wirklich testen.
Das sieht ja schon mal gut aus. Generell ist das Update des MultiNewsletter so programmiert, dass es alles problemlos funktioniert.
missmissr hat geschrieben:Eine Frage noch zu den E-Mail-Adressen Formaten: Im Vor- und Familienname dürfen aber schon Umlaute wie ü oder so sein? Oder kann das auch problematisch sein?
Sind bei mir völlig unproblematisch und es hat sich auch noch niemand beschwert.
missmissr hat geschrieben:Gibt es jetzt noch eine Möglichkeit, wie ich herausfinden kann, welche 75 User von den über 1007 den letzten Newsletter nicht erhalten haben? Hast du da eine Idee? Direkt in der Datenbank oder so? Ich sehe im Archiv ja jetzt schön, dass an 932 User verschickt wurde und mein Problem ist, dass ich die 75 nicht beschickten nicht erkennen kann.
Du bist die erste, die sich das wünscht. Da habe ich auf die schnelle keine Idee wie du das lösen kannst. Programmieren lässt sich das auf jeden Fall, ist aber zeitaufwändig. Die meisten Benutzer, die den Newsletter nicht erhalten haben, kannst du durch das Anmelde- / Updatedatum herausfiltern.

Hilft dir das weiter?

Liebe Grüße,

Tobias

missmissr
Beiträge: 175
Registriert: 9. Mär 2008, 18:36

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 18:35

Tobias Krais hat geschrieben:Hi missmissr,

Du bist die erste, die sich das wünscht. Da habe ich auf die schnelle keine Idee wie du das lösen kannst. Programmieren lässt sich das auf jeden Fall, ist aber zeitaufwändig. Die meisten Benutzer, die den Newsletter nicht erhalten haben, kannst du durch das Anmelde- / Updatedatum herausfiltern.

Hilft dir das weiter?

Liebe Grüße,

Tobias
Hallo Tobias,

Danke wieder für die schnellen profunden Antworten, mir würde es schon helfen, wenn ich wüsste, wonach der MultiNewsletter die Versandadressen beim Versand sortiert, dann kann ich nämlich finden, wer die letzten 75 waren, die nichts bekommen heben. Weil in der Ansicht vom Archiv sehe ich zwar alle 932 Empfänger, aber die sind in einer Reihenfolge sortiert, bei der ich das Sortierkriterium nicht erkennen kann.

Wie meinst du nach Anmelde- und Updatedatum?

Danke wieder,
missmissr.

Tobias Krais
Beiträge: 500
Registriert: 2. Okt 2006, 23:16
Wohnort: Lörrach
Kontaktdaten: Website

Re: Antwort auf Mailabbruch: Multinewsletter Addon Feedback

21. Nov 2016, 18:53

Hi missmissr,
missmissr hat geschrieben:mir würde es schon helfen, wenn ich wüsste, wonach der MultiNewsletter die Versandadressen beim Versand sortiert,
die werden nicht speziell sortiert. MySQL müsste also nach der ID sortieren
missmissr hat geschrieben:dann kann ich nämlich finden, wer die letzten 75 waren, die nichts bekommen heben. Weil in der Ansicht vom Archiv sehe ich zwar alle 932 Empfänger, aber die sind in einer Reihenfolge sortiert, bei der ich das Sortierkriterium nicht erkennen kann.
Kann es sein, dass du Benutzer hast, die gar keiner Gruppe zugeordnet sind? Dann müsstest du bei den Benutzern nach dieser "Gruppe" filtern und du hast schon die fehlenden Benutzer.
missmissr hat geschrieben:Wie meinst du nach Anmelde- und Updatedatum?
In der Benutzerübersicht gibt es die Spalte Anmeldedatum und Updatedatum. Alle Benutzer, die sich nach dem Newsletter angemeldet haben, haben damit auch den letzten Newsletter nicht erhalten.

Hilft dir das weiter?

Liebe Grüße,

Tobias

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Re: Multinewsletter Addon Feedback / Bugfix

22. Nov 2016, 10:47

Da möchte ich mich gern anschließen, denn das war schon bei der Urform des Multinewsletteraddons ein Problem für mich: das Rausfiltern der bereits versendeten aus der Gesamtgruppe, urmühsam :cry:
Wenn die Gruppe nicht mehr als 100 hat, geht´s ja noch locker, die übrigen einer neuen Gruppe zuzuweisen. Aber bei 1000?
Wäre es möglich, bei erfolgreichem Versand die article_id des zu versendenden Newsletters beim Empfänger einzutragen? Damit könnte ich zumindest in der Datenbank ausforschen, wer noch fehlt ...
Das wäre ein Feature, über das sich bestimmt viele freuen würden!
Nebenbei, der Multinewsletter ist mein liebstes Newslettertool, und ich verwende es schon viele Jahre bei vielen Kunden und bin froh über die stetige Weiterentwicklung!
lg,sue

Zurück zu „Allgemeines [R4]“