Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

TinyMCE nervt in 4.2.1

30. Mär 2010, 00:17

Pardon für den "unqualifizierten" Titel. Aber er entspricht der Situation.

Zur Zeit verwende ich ein Redaxo 4.1-System mit TinyMCE. Dafür habe ich die Button-Liste im Addon-Bereich angepasst und eine eigene *.css-Datei im files-Verzeichnis mit den Styles.

Das funktioniert seit Monaten einwandfrei.

Nun habe ich Redaxo 4.2.1 installiert (nur in einem Testverzeichnis auf dem selben Server) und die Inhalte von der bestehenden Seite importiert.
TinyMCE ist allerdings nur noch in der Grundkonfiguration verfügbar. Die eigenen Buttons fehlen, die Stylesheets fehlen auch.

Inzwischen habe ich die zuständige content.css-Datei gefunden in die nun die Stylesheets eingetragen werden. Das funktioniert auch, solange man keine Anweisungen wie "hover" oder ähnliches verwendet die eigentlich für die Links sind. Die werden dann weder in der Auswahlliste noch im Linkmenue angezeigt.

Das Modul für TinyMCE habe ich auch übernommen. Die Einstellungen für die Buttons sind wirkungslos. Wie und wo sie jetzt plaziert werden konnte ich trotz der tausenden von Dokumentationen nicht nachvollziehen. Ich habe so ziemlich jede Datei durchgesucht und bearbeitet. Es passiert nichts. Den Cache vom Browser und Redaxo habe ich unzählige Male geleert und Seiten neu aufgerufen.

Der Tag ist rum und ich habe eigentlich keine Lust mehr mich damit rumzuärgern. Warum muss man bei einem Update eigentlich die gesamte Konfiguration über den Haufen werfen?

Gibt es eine Möglichkeit das "alte" TinyMCE in Redaxo 4.2.1 zu integrieren? Oder hat irgendjemand eine einfach Anleitung wie man ein funktionierendes Tiny auf 4.2.1 updaten kann?

1000...0 Grüsse von einem maximal genervten "Teletubbie"
Daniel

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

30. Mär 2010, 10:14

Ich fass es nicht.
Nach dem nächtlichen Frust habe ich Redaxo 421 komplett gelöscht und neu installiert.
Jetzt ist auf einmal das Konfigurationsfenster für Tiny und einweiteres AddOn da. :shock:
Ich war schon am verzweifeln das ein mod_rewrite leichter zu konfigurieren ist als ein Tiny. Irgendwie war die Installation nicht vollständig gelaufen. Nur dass keinerlei Fehlermeldung kam sondern nur die Funktionen nicht zur Verfügung standen.
Jetzt muss ich nur noch lösen, warum er die css-Befehle für die Links nicht angezeigt werden.
:x

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

Zu früh gefreut

30. Mär 2010, 14:00

Eigentlich sah ja alles ganz gut aus.

Im Backend kann man alles editieren. Nur leider zeigt es keinerlei Wirkung.
Am Anfang standen wenigstens die "normalen" css-Klassen zur Verfügung. Die Linkklassen zeigt es einfach nicht mehr an. Mittlerweile zeigt das System überhaupt keine Styles mehr an. Vermutlich habe ich zuviele Ratschläge aus dem Forum genutzt. Tiny neu zu installieren brachte auch nix.

Wo die Eingaben aus dem Backend hingespeichert werden konnte ich noch nicht rausbekommen. Die Dateien im Addonverzeichnis haben sich nicht verändert. Freigaben sind alle da und die .htaccess sind ausser Betrieb zum testen.

Wie erkläre ich eigentlich dem Template wo es künftig die richtige css-Datei findet wenn nicht einmal ich sie finde? Ich hatte gehofft irgendwo einmal die Pfade für die gespeicherten Dateien zu finden.

4.2.1 ist (mal wieder) gecancelt. 4.1 läuft erstmal weiter.
Und dann ... mal sehn. Vielleicht klappt es ja mit 4.3 oder was auch immer.

netmanix

30. Mär 2010, 16:44

Kann Deinen Frust verstehen. TinyMCE ist in Redaxo so schlecht eingebunden bzw. fehlerhaft, dass es kaum zu gebrauchen ist.
Bilder werden nicht angezeigt, CSS lassen sich nicht editieren. (Falscher Pfad?), Links funktionieren nicht. Schade.
Das Forum ist voll damit. Aber leider wird keine aktualisierte Version des Addons veröffentlicht. Es ist eine Bastelei.

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

30. Mär 2010, 21:01

Hallo,
mal ein Plus hier denn So schlecht ist das nun auch wieder nicht :O).
Finde das ganz IO.
CSS lasst sich online editieren.
Bilder werden Angezeigt und gleich mit Image Reize überarbeitet.

Cheffchen

Benutzeravatar
Andreas.Eberhard
Beiträge: 653
Registriert: 4. Dez 2006, 17:03
Wohnort: Kirchheim bei München
Kontaktdaten: Website

31. Mär 2010, 20:19

Hallo Zusammen,

bitte mal die neue Beta des TinyMCE ausprobieren:
http://download.andreaseberhard.de/reda ... .beta1.zip

Ist noch nicht ganz komplett aber die ganzen Fehler des Tiny die
hauptsächlich auf falsche Dateirechte zurückzuführen sind sollten
damit behoben sein.

Beste Grüße
Andreas

Maw.
Beiträge: 129
Registriert: 4. Aug 2008, 10:05
Kontaktdaten: Website

31. Mär 2010, 21:04

super, dass der TinyMCE weiterentwickelt wird!
Scheint mit der neuen Version bisher bestens zu funktionieren (im Vergleich zu vorher!)

sueshi
Beiträge: 96
Registriert: 6. Feb 2007, 13:37
Wohnort: Österreich

Endlich ein TinyMCE, der funktioniert!

31. Mär 2010, 21:08

DANKE! DANKE! DANKE!!! :lol: :lol:

Mit dieser Version passt endlich alles, zumindest bei mir! Hatte bisher immer ein Problem mit der Linkmap im Tiny, der Link wurde nicht übernommen. Mit dieser Version tut´s genau das, was es soll.

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

31. Mär 2010, 21:37

Erst mal einen grossen Dank an "Goldfisch" für seine PN-Tipps wo Tiny überhaupt was ablegt.

Und noch etwas ist ganz wichtig. Da kommt man normalerweise gar nicht drauf...

Die CSS-Formate in Tiny dürfen nicht mit "mce..." anfangen.

Ich habe aus praktischen Gründen alle CSS-Formate die über das alte Tiny laufen mit den Anfangsbuchstaben "mce..." gekennzeichnet. Damit gleich zu erkennen ist wohin die zuzuordnen sind.
Im neuen Tiny werden diese Anfangsbuchstaben aber für die /* TinyMCE specific rules */ benutzt. Damit könne diese gar nicht interpretiert werden. Jetzt muss ich in der Datenbank erst einmal alle Einträge umbenennen damit ich überhaupt eine Chance hab das Ding zum laufen zu bringen.

Benutzeravatar
Andreas.Eberhard
Beiträge: 653
Registriert: 4. Dez 2006, 17:03
Wohnort: Kirchheim bei München
Kontaktdaten: Website

8. Apr 2010, 11:44

Hallo,

es gibt eine neue Version des TinyMCE-Addons
http://forum.redaxo.de/ftopic14324.html

Gruß
Andreas

Zurück zu „Allgemeines [R4]“