Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Benutzeravatar
CWS
Beiträge: 68
Registriert: 15. Jun 2014, 12:09

Re: Neues einfaches Blogsystem [TvsBlog]

14. Feb 2015, 09:15

Hey Leute,

das ist ja fein. Freu!

@morfer: Würde deiner Version noch den einen individuellen SEO Meta-Title hinzufügen wollen. Den habe ich in meiner umgebauten Version drin. Allerdings musste noch ne Kleinigkeit gemacht werden. Wenn man den SEO-Title nicht ausfüllt, das der orginal Beitragstitel, stattdessen angezeigt wird. Leider weiss ich nicht wie man das macht, mangels Kenntnissen.

Hätte vielleicht noch ne Idee für ein Modul, das die zuletzt geschriebenen Artikel ausgibt. ;-)

Gruß Christian :-)
Christian Haß - Spirituelle Heilung - - Spirituelle Heilerschule - - Spiritueller Shop - Schwierig sein kann es nur, weil du es so glaubst ;-)

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

Re: Neues einfaches Blogsystem [TvsBlog]

4. Apr 2015, 21:57

Ein ganz anders Problem ist noch dabei.
Sobald tvsblog aktiviert ist, fügt er im head-Bereich die Zeilen

Code: Alles auswählen

<link href="files/addons/tvsblog/wmuSlider/wmuSlider.css" type="text/css" rel="stylesheet" media="screen" />
<script src="files/addons/tvsblog/wmuSlider/jquery.wmuSlider.min.js" type="text/javascript"></script>
Google Pagespeed reklamiert das deutlich insbesondere bei mobilen Seiten. Selbst bei Desktop-PCs verliert man noch fünf Punkte.

Inzwischen versuche ich alle AddOns (z.B: Magnific Popup) rauszuschmeißen, die irgendwie js oder eigene CSS-Dateien mitbringen, die man nicht kombinieren oder an der passenden Stelle inline setzen kann. Auch wenn ich dann auf diese Funktionen verzichten muss. Nur bei tvsblog geht das natürlich nicht.

1000...0 Grüße
Daniel
Warum ich hier bin? Meine Frustrationsgrenze wurde schon lange nicht mehr vollständig ausgelotet ... :-)

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

4. Apr 2015, 22:26

Du kannst die Zeilen doch in der config.inc auskommentieren und dann selbst einfügen wo du sie haben willst.
Der beste Weg ist eh iw_assets ...

Gruß
Ralf
- Danke für Redaxo! -
http://www.prenzlweb.de

mot-K
Beiträge: 24
Registriert: 14. Okt 2014, 14:51

Re: Neues einfaches Blogsystem [TvsBlog]

10. Apr 2015, 18:21

Hallo,

ist es möglich, innerhalb von TvsBlog die Toolbar des Editors (in meinem Fall CKEditor) anzupassen?
Im CKEditor AddOn ist dies ja möglich.

Viele Grüße

Benutzeravatar
ralf.schlott
Beiträge: 625
Registriert: 5. Dez 2007, 21:22
Wohnort: Hamburch
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

10. Apr 2015, 20:01

Jo.

In der articles.inc.php ganz unten javascript vom CKeditor bearbeiten.
- Danke für Redaxo! -
http://www.prenzlweb.de

mot-K
Beiträge: 24
Registriert: 14. Okt 2014, 14:51

Re: Neues einfaches Blogsystem [TvsBlog]

11. Apr 2015, 14:05

Vielen Dank!

nicnacdeluxe
Beiträge: 8
Registriert: 6. Mär 2015, 18:33

Re: Neues einfaches Blogsystem [TvsBlog]

16. Apr 2015, 10:37

Hallo Leute,
ich habe mich gefragt ob es möglich ist die Art der generierten Artikel URLs abzuändern.

Momentan sieht die URL in etwa so aus

"/aktuelles/kategoriename/artikeltitel"


Als Endergebnis hätte ich gerne

"/aktuelles/jahr/monat/artikeltitel"

Ich habe mich bereits an der "urlRewrite.inc.php"-Datei versucht und dort beispielhaft den Kategorienamen in der generierten URL wegzulassen. Die URL wurde dann auch erfolgreich generiert ohne Kategorie, allerdings bekam ich nach Aufruf einen 404 Error.

Falls hier jemand weiter weiß bin ich dankbar um jeden Hinweis!

Viele Grüße

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

16. Apr 2015, 15:19

Ist auf jeden Fall machbar.

Du musst lediglich das Datum des Artikels mit auslesen und mittels seo42_appendToPath einhängen.
Poste doch mal deinen bisherigen Code der urlRewrite.php.

Hier mal ganz grob was zum basteln:

Code: Alles auswählen

Löschen
$pathname = seo42_appendToPath($pathname, $cat_title, $cat_id, $clang);
$pathname = seo42_appendToPath($pathname, $art_title, $art_id, $lang_id);

Erweitern
$art_datum = $sql_art->getValue("createdate"); //Datum
$jahr = date("Y",$art_datum); // Beispiele: 2004 oder 2015
$monat = date("m",$art_datum); // 01 bis 12

$art_title = $jahr."/".$monat."/".$art_title;

$pathname = seo42_appendToPath($pathname, $art_title, $art_id, $lang_id)

nicnacdeluxe
Beiträge: 8
Registriert: 6. Mär 2015, 18:33

Re: Neues einfaches Blogsystem [TvsBlog]

16. Apr 2015, 16:35

Vielen Dank!
Ich werde den Code mal in meiner urlRewrite.inc.php testen! Habe bisher nur jeweils die erste $pathname Variable , also die Zeile

Code: Alles auswählen

$pathname = seo42_appendToPath($pathname, $cat_title, $cat_id, $clang);
auskommentiert und es so getestet.

Ich versuche es mal mit den von dir geposteten Änderungen.

morfer
Beiträge: 105
Registriert: 24. Mär 2009, 01:58

Re: Neues einfaches Blogsystem [TvsBlog]

16. Apr 2015, 16:43

PS: Du musst die Änderungen natürlich in allen 3 Funktionen durchführen!

Also in getTVSBlogURL, tvsblog_extended_urls und tvsblog_extended_sitemap.

nicnacdeluxe
Beiträge: 8
Registriert: 6. Mär 2015, 18:33

Re: Neues einfaches Blogsystem [TvsBlog]

16. Apr 2015, 17:21

Ich habe die Änderungen (in abgewandelter Form) eingebaut und es geht!

Wichtig ist auch, dass man nach Änderungen an der Sitemap auch noch den Systemcache löscht (das habe ich dummerweise bei meinen letzten Versuchen vergessen :lol: )

In der getTVSBlogUrl() muss man außerdem den SQL Select Query ergänzen, damit auch das Datum selektiert wird.

Code: Alles auswählen

$query_art = "SELECT  a.title as art_title, a.clang as art_clang, a.id as art_id, a.categories, c.title as cat_title, c.id as cat_id, a.create_date as create_date
					  FROM " . $tvsblog_art_table . " as a
					  INNER JOIN 
					  " . $tvsblog_cat_table . " c ON (a.categories  =  c.id)
					  WHERE a.status = 1 
					  AND a.id = ". $m_post_id ." 
					  AND a.clang = ". $clang
					  ;
Die folgenden Änderungen habe ich in allen 3 Funktionen durchgeführt

Auskommentiert/gelöscht habe ich jeweils

Code: Alles auswählen

$pathname = seo42_appendToPath($pathname, $cat_title, $cat_id, $clang);
$pathname = seo42_appendToPath($pathname, $art_title, $art_id, $lang_id);
Ergänzt habe ich jeweils

Code: Alles auswählen

$art_datum = $sql_art->getValue("create_date"); //Datum

$jahr = date("Y",$art_datum); // Beispiele: 2004 oder 2015
// Jahr dem Pfad hinzufügen
$pathname = seo42_appendToPath($pathname, $jahr, $art_id, $clang);

$monat = date("m",$art_datum); // 01 bis 12
// Monat dem Pfad hinzufügen
$pathname = seo42_appendToPath($pathname, $monat, $art_id, $clang);

// Artikeltitel hinzufügen
$pathname = seo42_appendToPath($pathname, $art_title, $art_id, $clang);

Wie oben zu sehen ist müssen Jahr, Monat und Titel einzeln über die seo42_appendToPath() Funktion hinzugefügt werden. Der Versuch einen String zu bauen und den hinzuzufügen hat nicht funktioniert. Daraus wurde dann "/aktuelles/2015-04-titel". Wenn man den Text so formatiert haben möchte, kann man natürlich diese Variante wählen wie morfer weiter oben beschrieben hat :)

Ich bin mir lediglich nicht sicher ob es legetim ist als 3. und 4. Parameter immer $art_id und $clang zu verwenden.

Vielen Dank nochmal an dich morfer!

Benutzeravatar
karlnappmitdenasskap
Beiträge: 116
Registriert: 18. Aug 2012, 20:30
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

26. Aug 2015, 13:50

Hallo,

ich wollte mal nachfragen, ob es bzgl. der geplanten Kommentarfunktion schon etwas Neues gibt?!

Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

25. Sep 2015, 13:35

Alos ich fände mal ganz interessant, es überhaupt installiert zu bekommen. Er sagt zwar, er hat ImageManager Typen angelegt und das jQuery eingebunden sein muss etc., aber das war es dann auch - keine Erfolgsmeldung zum Install. Und die AddOn-Liste wird nicht mehr aufgebaut...

Auf REX 4.6.1 - was ja laut der Beschreibung zur V1.4.2 von TVSBlog laufen soll...

Was nu?
(Ja, ich kann auch im AddOn rumfummeln - mach ich evtl. auch. Aber vielleicht will Michael auch mal nach dem Fehler schauen ;) )

Gruß Tim

Benutzeravatar
michaelwandel
Beiträge: 331
Registriert: 1. Jul 2010, 13:54
Wohnort: Köln
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

25. Sep 2015, 14:34

Sooo, hallo erstmal :-)

Kommentarfunktion läuft, Installation sollte gehen, es läuft auf haufenweisen Installationen ;-)

Ich denke in den nächsten Wochen kommt die aktuelle Version, denke vor dem Redaxo-Tag :)I

Evtl. mal schauen welchen Rewriter Du nutzt, läuft auf jeden Fall mit SEO aktuellster Version :)

Gruß, Michael :)

Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

25. Sep 2015, 14:51

Sorry, hallo erstmal :lol:
hm, ich "versuche" 1.4.2 mit SEO42 auf REX 4.6.1 zu installieren und er kommt - wie gesagt - dazu mir zu sagen was er installiert haben will, aber der SUCCESS-State kommt nicht und komplette AddOns-Seite wird nicht weiter aufgebaut...

Ich hab es jetzt auch nochmal gelöscht, über Installer heruntergeladen und dann versucht zu installieren.

Siehe hier: https://monosnap.com/file/OV7QGODDgCV7a ... 1kyR8krc6C#

Gruß Tim

teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

Re: Neues einfaches Blogsystem [TvsBlog]

27. Sep 2015, 17:00

Pardon wenn ich noch einmal reinplatze …

Aber ich habe ein Problem mit den Metadaten.
Auf einer neuen Seite (Rex 4.6.1) habe ich tvsblog 1.4.2 und SEO42 4.1.2 laufen.

Leider bleiben die Zeilen

Code: Alles auswählen

<meta name="description" content="" />
<meta name="keywords" content="" />
immer leer. Am Anfang des Threads gab es einmal eine Beschreibung wie man die Zeilen füllt. Aber irgendwie gibt das nur einen Fehlermeldung. Tvsblog und SEO42 sind ja inzwischen weiterentwickelt worden.
Gibt es einen einfacheren Trick wie man die Zeilen aktiviert. Gockel und Co. Sollen ja etwas zu lesen haben.


1000...0 Grüße
Daniel
Warum ich hier bin? Meine Frustrationsgrenze wurde schon lange nicht mehr vollständig ausgelotet ... :-)

Benutzeravatar
CWS
Beiträge: 68
Registriert: 15. Jun 2014, 12:09

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 09:35

Moin, probier mal das hier.....

Code: Alles auswählen

<?php

// ------ DESCRIPTION/KEYWORDS
   
   $meta_title         = seo42::getTitle();
   $meta_description   = seo42::getDescription();
   $meta_keywords      = seo42::getKeywords();

// TVSBlog-Meta-Daten
   $tvsblog_post_id   = rex_get('post_id', 'int', -1);
   if ($tvsblog_post_id > -1) {
      $tvsblog_table_pre   = $REX['TABLE_PREFIX'] . $REX['ADDON']['rxid']['tvsblog'];
      $tvsblog_art_table   = $tvsblog_table_pre . "_articles";
      $sql = new rex_sql();
      $sql->setQuery("SELECT * FROM " . $tvsblog_art_table . " WHERE id = " . $tvsblog_post_id);

      if ($sql->getRows() > 0 ) {
         
         $meta_title      = $sql->getValue('meta_title');
         $meta_keywords   = $sql->getValue('meta_keywords');
         $meta_description= $sql->getValue('meta_description');
      }
   }
?>

Code: Alles auswählen

<title><?php echo $meta_title; ?></title>
<meta name="description" content="<?php echo $meta_description; ?>">

Lg Christian :-)
Christian Haß - Spirituelle Heilung - - Spirituelle Heilerschule - - Spiritueller Shop - Schwierig sein kann es nur, weil du es so glaubst ;-)

Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 10:17

Hallo zusammen,

könnte es bei mir an den AddOns liegen, die ich alle installiert habe (oder das ich lokal installiert habe)?

REX 4.6.1
mit folgenden AddOns:
- be_dashboard mit userinfo
- be_search
- be_style
- be_utilities plus alle plugins
- ckeditor
- clearcache
- cronjob mit beiden plugins
- email_obfuscator
- image_manager
- magnific_popup
- metainfo
- phpmailer
- rex_mobile (deinstalliert - Installversuch nicht erfolgreich)
- rex_multiupload
- seo42 mit min42
- slice_status
- sliceshift (deinstalliert - Installversuch nicht erfolgreich)
- string_table
- textile
- xform

Irgendjemand irgendeine Idee??

LG Tim
Zuletzt geändert von elricco am 28. Sep 2015, 10:40, insgesamt 1-mal geändert.

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 10:33

@elricco: hui ganze 8 addons von diesem rexdude im einsatz. nicht schlecht ;)
Es erscheint vermutlich ne fehlermeldung die du (wegen server einstellung) nicht anzeigst.
Pack mal dass in die redaxo/index.php ganz nach oben: http://stackoverflow.com/a/6575502

Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 10:47

@rexdude: ja die Dinger sind ja auch fein gecodet und funktionieren gut und sind immer aktuell ;)
Hätte ich auch mal drauf kommen können - aber dann bekomm ich direkt mal das hier:
Notice: Undefined index: tvsblog in /website/redaxo/include/addons/tvsblog/install.inc.php on line 12

Notice: Undefined index: image_manager in /website/redaxo/include/addons/tvsblog/install.inc.php on line 30

Notice: Undefined index: image_manager in /website/redaxo/include/addons/tvsblog/install.inc.php on line 32

Notice: Undefined index: image_manager in /website/redaxo/include/addons/tvsblog/install.inc.php on line 35

Image_Manager-Bildtyp und Effekt wurde angelegt!

Bitte beachten das jQuery (http://jquery.com) vorausgesetzt wird!

Notice: Undefined index: tvsblog in /website/redaxo/include/addons/tvsblog/install.inc.php on line 38

Warning: require_once(/website/redaxo/include/addons/tvsblog/classes/../../seo42/classes/class.rexseo_rewrite.inc.php): failed to open stream: No such file or directory in /website/redaxo/include/addons/tvsblog/classes/urlRewrite.inc.php on line 15

Fatal error: require_once(): Failed opening required '/website/redaxo/include/addons/tvsblog/classes/../../seo42/classes/class.rexseo_rewrite.inc.php' (include_path='.:/Applications/MAMP/bin/php/php5.6.10/lib/php') in /website/redaxo/include/addons/tvsblog/classes/urlRewrite.inc.php on line 15
Wühl ich mich mal durch, aber Tipps nehme ich gerne ;)
LG Tim

P.S.: DIe Seite ist unter meineseite.localhost im MAMP eingestellt, also nix mit Unterverzeichnissen etc.

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 10:57

Thx :D
Ach ja das alte Problem: In besagter Zeile 15 muss statt rexseo --> seo42 stehen.

Benutzeravatar
CWS
Beiträge: 68
Registriert: 15. Jun 2014, 12:09

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 10:59

@elricco: Schreib mir mal ne PN, dann bekommst du ne Version die gehen sollte...

Mit Emailadresse!

LG Christian

Ps: Da war der Dude wieder schneller. ;-)
Christian Haß - Spirituelle Heilung - - Spirituelle Heilerschule - - Spiritueller Shop - Schwierig sein kann es nur, weil du es so glaubst ;-)

Benutzeravatar
RexDude
Beiträge: 2543
Registriert: 22. Apr 2010, 11:24

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 11:04

@Christian: Dafür ist aber dein Service unschlagbar ;)

Benutzeravatar
CWS
Beiträge: 68
Registriert: 15. Jun 2014, 12:09

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 11:15

@RexDude: Wenn ich helfen kann gerne!

@elricco: Mail ist raus...
Hab mir da einen individuellen Metatitle eingebaut um den zum Einsatz zu bringen musst du diese Zeile im Template ändern:

Code: Alles auswählen

$meta_title      = $sql->getValue('meta_title');
zu

Code: Alles auswählen

$meta_title      = $sql->getValue('seo_title');
Lg Christian
Christian Haß - Spirituelle Heilung - - Spirituelle Heilerschule - - Spiritueller Shop - Schwierig sein kann es nur, weil du es so glaubst ;-)

Benutzeravatar
elricco
Beiträge: 197
Registriert: 22. Jun 2007, 00:48
Wohnort: Bochum
Kontaktdaten: Website

Re: Neues einfaches Blogsystem [TvsBlog]

28. Sep 2015, 11:20

@christian: Ja, gerade angekommen - schau ich mir gleich mal an und leg es mir dann auch in mein Clean-Install ;)

@rexdude: Vielen Dank für die Hilfe :-)

LG Tim

P.S: Erfolgsmeldung was den Install angeht :lol:

Zurück zu „Allgemeines [R4]“