Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Benutzeravatar
Phlogiston
Beiträge: 219
Registriert: 19. Mär 2008, 13:13
Kontaktdaten: Website

Eingabe in xform ist nicht sichtbar

17. Sep 2015, 09:35

Hallo,
habe via xForm eine kleine Buchungsanfrage erstellt. Leider sind im Frontend die Eingaben nicht sichtbar.
Also die eingegebenen Daten, Namen, Email etc., werden per Email zwar überragen sind im Frontend aber
nicht zu sehen. Ist jetzt nicht mein erstes xForm Formular und bisher hat immer alles geklappt. Hier steh ich aber leider gerade auf dem Schlauch. Kann mir da vielleicht jemand aus der Klamme helfen?
Redaxo 4.6.1
php 5.4

Benutzeravatar
Thomas.Blum
Entwickler
Beiträge: 5063
Registriert: 24. Aug 2004, 22:11
Wohnort: Dresden
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 10:09

Hej,

was heißt nicht zu sehen genau?

Direkt beim eintragen in das Formular? Oder nach dem Versenden auf einer Übersichtsseite? Oder im Backend fehlt der Eintrag in der Tabelle?

Bitte genauer beschreiben!

vg Thomas

Benutzeravatar
Phlogiston
Beiträge: 219
Registriert: 19. Mär 2008, 13:13
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 10:40

"nicht zu sehen" meint beim Eintrag im Frontend in die entsprechenden Eingabefelder.
Im backend funktioniert alles bestens
Eine Tabelle zu Ablage in einer Datenbank habe ich nicht angelegt. Ist das zwingend erforderlich?
Eigentlich soll nur eine Email verschickt werden.

Benutzeravatar
Thomas.Blum
Entwickler
Beiträge: 5063
Registriert: 24. Aug 2004, 22:11
Wohnort: Dresden
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 11:00

Phlogiston hat geschrieben:"nicht zu sehen" meint beim Eintrag im Frontend in die entsprechenden Eingabefelder.
Dann probier mal die Schriftfarbe via CSS zu ändern.

vg Thomas

Benutzeravatar
Phlogiston
Beiträge: 219
Registriert: 19. Mär 2008, 13:13
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 13:48

negativ
Es existiert in den Eingabefelder "kein" Eintrag. Ich kann also auch nichts invertieren. Da ist nichts.
Im Eingabefeld "Mitteilung" funktioniert alles bestens.
Auswahlfelder (Mann/Frau, Datumsfelder) funktionieren bestens
Lediglich in die Felder "Name" und "Email" läßt sich nichts eintragen.
Das sind die xform Felddefinitionen:
text|name|Name:
email|email|Email:
Die "versteckten" Eingaben werden aber beim Emailversandt korrekt mitverschickt.
Modul aktualisieren hat nichst gebracht.
Emailversandt per vordefinierter Aktion.
:?: :?: :?:

Benutzeravatar
Thomas.Blum
Entwickler
Beiträge: 5063
Registriert: 24. Aug 2004, 22:11
Wohnort: Dresden
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 16:01

Wenn da nichts ist, wie kann dann was in der E-Mail auftauchen?

Benutzeravatar
Phlogiston
Beiträge: 219
Registriert: 19. Mär 2008, 13:13
Kontaktdaten: Website

Re: Eingabe in xform ist nicht sichtbar

17. Sep 2015, 17:25

o.k.
Problem war, dass die Boxen ein css stil hatten mit dem Namen text. Da waren 80px padding-left drin.
Die Einträge waren also da, nur eben rechts rausgeschoben. :oops:
Viele Köche.... und so.
Vielen Dank für deine Hilfe und sorry für den blöden Fehler.

Zurück zu „Allgemeines [R4]“