steri
Beiträge: 364
Registriert: 12. Jul 2007, 14:59

probleme mit Smooth Gallery // Mootools

12. Jul 2007, 15:11

Hallo!

Ich möchte gerne die Smooth Gallery verwenden. Im Backend funktioniert das Ganze (sehe die bilder usw.); Im Frontend bekommen ich aber folgende Fehlermeldung:

Code: Alles auswählen

Warning: Division by zero in /www/htdocs/aufwind/redaxo/redaxo/include/classes/class.article.inc.php(179) : eval()'d code on line 128
außerdem ist kurz ein bild zu sehen ist aber dann sofort wieder weg.
ich habe "Mighty Accordion", "Slightbox" und eben "SmoothGallery" (aus den Mootools) hinzugefügt. Die beiden ersteren fnktionieren einwandfrei. Ansonsten verwende ich keine JS.
Im Template (verwende die Standardinstallation von 3.2.2. ) sieht der code so aus:

Code: Alles auswählen

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">

<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/mootools.v1.11.js"></script>
<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/mootools.slfx.js"></script>

<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/slightbox.js"></script>
<link rel="stylesheet" type="text/css" href="<? // echo $REX['HTDOCS_PATH'] ?>files/slightbox.css" media="screen" />

<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/jd.gallery.js"></script>
<link rel="stylesheet" type="text/css" href="<? // echo $REX['HTDOCS_PATH'] ?>files/jd.gallery.css" media="screen" />

<head>
und

Code: Alles auswählen

<!-- end #content -->
<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/mootools.acc.js"></script>
<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/slightbox.js"></script>
<script type="text/javascript" src="<? // echo $REX['HTDOCS_PATH'] ?>files/jd.gallery.js"></script>

</div> <!-- end #website -->
muss ich ev. etwas bei den aktionen des "SmoothGallery" Moduls etwas umstellen? wäre um hilfe sehr dankbar!

steri
Beiträge: 364
Registriert: 12. Jul 2007, 14:59

12. Jul 2007, 21:25

... oder mal anders gefragt; gibt es irgendwo eine anleitung wie man die smooth gallery richtig einbindet? brauch ich überhaupt die anderen sachen der mootools?
ich möchte eigentlich nur eine slideshow machen.

Joachim.Dörr
Beiträge: 1405
Registriert: 7. Apr 2006, 01:49
Kontaktdaten: ICQ Website

12. Jul 2007, 22:15

ich bin aus gegebenem anlass dran eine lückenlose beschreibung zu schreiben - ist aber arbeit und ich hab kaum zeit dazu :(

die module funktionieren ich setze sie an verschiedenen stellen ein. hier eine demo zur smoothgallery: http://pixelworks.info/index.php?article_id=6

das javascript für die gallery nur im head einbinden - das script für das mighty accordion nur unterhalb des contents.

lg
Joachim

ps. am besten einfach mal auf einem testserver testen unter einem cleanen redaxo

steri
Beiträge: 364
Registriert: 12. Jul 2007, 14:59

Lösung meines Problems

13. Jul 2007, 13:31

LÖSUNG:

ich hatte immer folgende Fehlermeldung im Front End:

Code: Alles auswählen

Warning: Division by zero in /www/htdocs/w006aeca/redaxo/include/classes/class.article.inc.php(179) : eval()'d code on line 79
scheinbar funktioniert die SmoothGallery nicht mit den Bildern der Simpel Demo. Als ich dann eigene Bilder hochgeladen habe und diese verwendet habe, hat die SmoothGallery funktioniert. Aufpassen sollte man bei den Dateinamen und Titel der Bilder: am besten Sonderzeichen und leerzeichen vermeiden.

Zurück zu „Allgemeines [R3]“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste