Hallo, lieber Forum Benutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via https://slack.com/ viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen bei Fragen/Problemen aktuell die Frage (zusätzlich) im Slack zu stellen. Dort sind viele kompetente REDAXO Benutzer aktiv und beantworten gerne (Anfänger)Fragen.

Selbst einladen kannst Du dich hier: http://redaxo.org/slack/

Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Rumi
Beiträge: 73
Registriert: 20. Aug 2010, 01:35

Problem mit Textile / Markitup mit Redaxo 4.4.1 und PHP 7

1. Nov 2018, 11:22

Hallo

ich verwende Redaxo 4.4.1, und meine Seiten kamen nach dem Server-Update auf PHP 7 nur noch blank daher.

Ich habe gerade die class.rex_sql.inc.php von RexDude eingesetzt (herzlichen Dank dafür!), und die Struktur kommt schon mal wieder. Nur leider wird kein Inhalt angezeigt, welcher mit dem AddOn Textile gemacht wurde (d.h. mehr oder minder der gesamte Inhalt). Muss ich eine neuere Version von Textile installieren? Oder kann ich das Textile AddOn abändern? Was muss ich beachten?

Ich nehme an, Textile verwendet eine nicht mehr gültige mySQL Abfrage (welche nicht vom "Hack" von RexDude abgefangen wird), habe aber keine gefunden im Code.

Ich habe versucht, statt mit Textile mit Markitup den Text-Inhalt darzustellen, aber da wird alles als plain text angezeigt (= keine Formatierung ausser Umbrüche; HTML-Tags etc. werden nicht angewandt, sondern ausgeschrieben), inklusive dem, was ich im Modul-Output eingetragen habe (welchen ich von hier habe: https://github.com/jdlx/rex_markitup/bl ... ME.textile, "Minimaler Modul Code" - das gilt aber wohl nicht für 4.4.1?).

Ich habe schon länger nicht mehr mit Redaxo gearbeitet, und mache wahrscheinlich fundamentale Fehler. Trotzdem - oder erst recht - bin ich sehr dankbar für Eure Hilfe!

Rumi
Beiträge: 73
Registriert: 20. Aug 2010, 01:35

Re: Problem mit Textile / Markitup mit Redaxo 4.4.1 und PHP 7

1. Nov 2018, 11:29

Hab jetzt REX_HTML_VALUE[1] im Output meines Markitup Moduls, und kann damit zumindest HTML-Text ausgeben. Eine bessere Lösung wäre nach wie vor willkommen!

Rumi
Beiträge: 73
Registriert: 20. Aug 2010, 01:35

Re: Problem mit Textile / Markitup mit Redaxo 4.4.1 und PHP 7

2. Nov 2018, 14:17

Ich kann nun allen Text als HTML einfüllen, was mir ganz recht ist. Allerdings habe ich soeben festgestellt, dass auch das AddOn Sidebar Box keinen Text anzeigt. Hmmm. Die Suche geht weiter.

Hilfe ist nach wie vor sehr willkommen!

Zurück zu „AddOns / Packages [R5]“