Hallo, lieber Forumbenutzer. Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen Möglichkeiten der Kommunikation ist das Forum ein wenig eingeschlafen und weniger Nutzer benutzen das Forum aktiv (trotzdem lohnt es sich evtl. hier nach Lösungen zu suchen oder seine Frage zu stellen).

Wir empfehlen, für deine Fragen/Probleme aktuell (zusätzlich) Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
w.busch
Beiträge: 68
Registriert: 29. Nov 2011, 16:16
Wohnort: 38173 Dettum
Kontaktdaten: Website

rex_config::set schreibt keine Umlaute in rex_config

16. Aug 2018, 14:01

Hallo,
ich bekomme einen leeren Wert in der Tabelle rex_config, wenn ich einen String mit Umlaut eintragen will.
Beispiel:
rex_config::set($addon,'vorname','Günter'); liefert leeren Wert für den Vornamen
rex_config::set($addon,'vorname','Gunther'); liefert den gewünschten Vornamen
Was ist zu tun?
Wolfgang Busch

w.busch
Beiträge: 68
Registriert: 29. Nov 2011, 16:16
Wohnort: 38173 Dettum
Kontaktdaten: Website

Re: rex_config::set schreibt keine Umlaute in rex_config

16. Aug 2018, 18:04

Ich habe jetzt zwar eine eine (Not)Lösung:
Vor dem Schreiben (set) den Wert utf8-kodieren und nach dem Auslesen (get) wieder utf8-dekodieren.
Ist aber sicher nicht so gemeint, oder?
Fehler beim insert/update im Rahmen von rex_config::set()?
Wolfgang Busch

Zurück zu „AddOns / Packages [R5]“