Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
Do it
Beiträge: 5
Registriert: 25. Okt 2010, 13:35

TinyMCE und utf8

25. Okt 2010, 13:59

Nach Umstellung von Redaxo und Datenbank auf utf8 klappt´s bisher eher suboptimal. Die templates sind auf ut8-Kodierung geändert, Texte die hier implementiert sind, werden einwandfrei ausgegeben.

Anders bei den Texten, die mit TinyMCE editiert werden. Sie erscheinen zwar im Frontend normal, im Quelltext werden Umlaute aber durch Sonderzeichen ersetzt. Wird Tiny deaktiviert und die Artikel im Quelltext editiert, kommen Umlaute auch im Quelltext richtig.

Ich habe schon diverse Lösungsansätze hier im Forum durchforstet, geholfen hat bisher nichts. Habt Ihr eine Idee?

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

Re: TinyMCE und utf8

25. Okt 2010, 14:38

Do it hat geschrieben:Sie erscheinen zwar im Frontend normal, im Quelltext werden Umlaute aber durch Sonderzeichen ersetzt. Wird Tiny deaktiviert und die Artikel im Quelltext editiert, kommen Umlaute auch im Quelltext richtig.
Was verstehst unter Umstellung auf utf-8?
Template/Redaxo/Datenbank (und natürlich den Inhalt der Datenbank)?

Umlaute aber durch Sonderzeichen ersetzt, meinst sowas "Â"? dann stimmt die Codierung nicht.
Bei mir macht TinyMCE das ü in ü wie es sein soll.

Cheffchen

Do it
Beiträge: 5
Registriert: 25. Okt 2010, 13:35

25. Okt 2010, 16:02

Hallo Cheffchen,

umgestellt ist alles, also Template/Redaxo/Datenbank/Inhalte.

Umlaute der Artikel werden im Browser richtig dargestellt, aber im Quelltext wird aus ä eben ä

Das ist bei anderen Sites/CMS nicht so. Quältext soll halt auch schön sein...

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

25. Okt 2010, 16:57

Hallo,

das ist aber utf-8 :O),

Was du suchst ist RAW.
Ich weis nicht ob dies richtiger ist bei anderen CMS und ob das schöner ist? keine Ahnung.

Das solltest vielleicht in einen neuen Beitrag klären ob TinyMCE mit RAW besser ist als UTF-8 und je nach ergebnis ob das mit Radaxo dann überhaupt funzt ohne das System zu sehr ändern zu müssen.

PS: habe gerade bei ikea geschaut die haben utf8 und ä im Quellcode !?

Cheffchen

Do it
Beiträge: 5
Registriert: 25. Okt 2010, 13:35

25. Okt 2010, 18:01

RAW ist mir schon mal untergekommen, ich konnte damit aber nichts anfangen. Danke für den Hinweis, ich suche mal in der Richtung!

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

25. Okt 2010, 18:03

Cheffchen hat geschrieben:[...] ob TinyMCE mit RAW besser ist als UTF-8 [...]
Nur "TinyMCE mit RAW" ist "UTF-8"!

Siehe auch: http://forum.redaxo.de/ftopic12555.html ... inymce+raw
LG,
Xong

Bild Määääääääääääääääääääääääh!

Do it
Beiträge: 5
Registriert: 25. Okt 2010, 13:35

25. Okt 2010, 19:08

Den thread habe ich gesehen, kann ihn allerdings nicht nachvollziehen.

Wenn ich den code von Andreas in das Eingabemodul setzte, gibt´s beim Aufruf des Artikels eine Fehlermeldung.

Benutzeravatar
Xong
Beiträge: 2081
Registriert: 5. Jun 2008, 08:30
Wohnort: Halle (Saale)

25. Okt 2010, 19:26

Wie sieht denn der Moduleingabecode aus, der funktioniert?
LG,
Xong

Bild Määääääääääääääääääääääääh!

Benutzeravatar
Cheffchen
Beiträge: 1809
Registriert: 3. Mär 2009, 13:51
Wohnort: Berlin
Kontaktdaten: Website

25. Okt 2010, 21:00

Hallo,

ok ich habe das jetzt bei mir in raw geändert.
Alle zeichen werde 1zu1 übernommen egal ob ä® oder oder.
Wieso ist das eigentlich nicht Standard in Redaxo?

/files/addons/zinymce/tiny_mce/tiny_mce.js
Ich habe einfach die Default settings geändert, jetzt bloss noch jeden block mal öffnen und speichern.

Vorteil: das schöne, die Konfiguration bei R4.2 funzt weiter und bei allen Module mit Tiny ab sofort.
Nachteil: beim update auf neues Redaxo muss man daran denken und wenn nicht ist auch nicht weiter schlimm :O).

Oder übersehe ich da was?

Cheffchen

Do it
Beiträge: 5
Registriert: 25. Okt 2010, 13:35

26. Okt 2010, 12:29

:D Die Änderung auf raw ist die Lösung!

Danke für die Hilfe.

Benutzeravatar
chandany
Beiträge: 32
Registriert: 9. Nov 2006, 21:12
Wohnort: Hamburg

Re:

4. Jan 2012, 23:40

Do it hat geschrieben::D Die Änderung auf raw ist die Lösung!

Danke für die Hilfe.
Auch unter REX432 Community ;)
Habe lange gebraucht bis ichs verstanden habe. :roll:
Hier die Kurzanleitung:
redaxo/include/addons/tinymce/classes/class.tinymce.inc.php
zeile 512 einfügen

Code: Alles auswählen

		// UTF8 :
		$configout .= $n . '  entity_encoding : \'raw\','; //numeric, named, raw, //http://www.tinymce.com/wiki.php/Configuration:entity_encoding
		//$configout .= $n . '  entity_encoding : \'xml\','; //http://www.tinymce.com/wiki.php/Configuration:encoding
Jetzt bleibt bei RSS2 Vallidem Code nur noch das d... <p> zu entfernen. Hat da jemand ne :idea: Idee?????
bis bald.
-----
Testumgebung REX4_4_1 | XAMPP 1.7.3 | Apache/2.2.14 (Win32) DAV/2 PHP/5.3.1
| MySQL-Zeichensatz: UTF-8 general (utf8)
----

Zurück zu „Allgemeines [R4]“