Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
teletubbie
Beiträge: 86
Registriert: 5. Aug 2008, 18:08

Login wie in der Demo in eine laufende Seite einbauen.

21. Mär 2013, 19:50

Nach dem Update auf ein aktuelleres Redaxo 4.4.1 dachte ich, das mit Ein- und Ausloggen funktioniert. Aber es läuft sehr holprig und oftmals tut sich nix. Bisher hatte ich im Haupttemplate oben ein Authentifizierungstemplate eingebunden. Zudem gab es ein Template für das Login- und Logoff-Fenster. (1012 - COM-Template - Basis – Authentifizierung / 1014 - COM-Template - Basis – Userloginfenster).

Mit dem neueren Community-AddOn scheint man das ja nicht mehr zu brauchen und der gesamte Vorgang wird über die Xform-Artikel gelöst. Sieht in der Demo auch richtig schick aus. Leider habe ich nicht nachvollziehen können, wie diese Authentifizierung von statten geht und wo man was einbinden muss. Eine aktuelle Beschreibung habe ich auch nicht gefunden. Das »alte Verfahren« funktioniert nur noch teilweise. Witzigerweise wird der Login-Artikel von Xform ohne dieses alte Template nicht angezeigt. Aus dem Template(s) in der Demo werde ich nicht schlau. Das anlegen der Artikel für Login und Logoff ist kein Problem. Zumindest das Login funktioniert auch darüber, immer vorausgesetzt, das alte Auth.-Template ist eingebunden. Userinfo ist auch kein Problem. Den Weg zum Logoff gibt es aber nicht. Irgendwie läuft das in der Demo anders und unkomplizierter.

Gibt es irgendwo eine Schritt für Schritt Erklärung welchen Brocken man wo hinkopieren muss, damit einfach das An- und Abmelden wie in der Demo funktioniert. Im AddOn selbst ist das Auth-Plugin usw. natürlich aktiv. Gerade diesen Login-Logoff-Button oben links kann ich nirgendwo zuordnen. (Nein, Firebug bringt mich auch nicht weiter.)
Irgendwas muss man im Haupttemplate noch einfügen. Aber alles was ich ausprobiert habe funktioniert nicht. Es muss doch ganz einfach gehen.

1000...0 Grüße
Daniel
Warum ich hier bin? Meine Frustrationsgrenze wurde schon lange nicht mehr vollständig ausgelotet ... :-)

Zurück zu „Allgemeines [R4]“