Hallo,

Wir haben in letzter Zeit festgestellt, dass die Kommunikation via Slack viel schneller und zielführender ist als ein Beitrag im Forum. Aufgrund der neuen und besseren Möglichkeiten der Kommunikation haben wir uns entschlossen das Forum nur noch als Archiv zur Verfügung zu stellen. Somit bleibt es weiterhin möglich hier nach Lösungen zu suchen. Neue Beiträge können nicht mehr erstellt werden.

Wir empfehlen, für deine Fragen/Probleme Slack zu nutzen. Dort sind viele kompetente Benutzer aktiv und beantworten jegliche Fragen, gerne auch von REDAXO-Anfängern! Slack wird von uns sehr intensiv und meistens "rund um die Uhr" benutzt :-)
Selbst einladen kannst Du dich hier: http://redaxo.org/slack/
matthias
Beiträge: 4
Registriert: 18. Jan 2007, 14:33

JOIN Problem unter MySQL 5.0.18

18. Jan 2007, 14:54

Hallo Liebe REDAXO-Gemeinde,
wir sind völlig begeistert von redaxo. Leider haben wir ein kleines Problem unter MySQL 5.0.18. Den dazu gehörigen Artikel haben wir schon durch.
http://wiki3.redaxo.de/index.php?n=R3.FAQ#mysql5

Derzeit erscheint bei uns in Redaktionsbereiche redaxo keine Modultitel. Wenn man als eine Seite aufruft dann sind zwar drei Module enthalten aber der eigentlich fett markierte Modultitel fehlt und ist leer. Das Modul funktioniert aber beim Aufruf editieren. Es gibt noch an anderen Stellen (Bild einfügen, eigene Auflistung) ein seltsames verhalten.

Wir befürchten, das wir die MySQL-JOIN-Abfrage überall ändern müssen (wie im oberen Link beschrieben). Jetzt sind wir uns aber nicht sicher. Ob das so einfach geht.

Hat jemand hier vielleicht Erfahrung mit der MySQL-Version und hat das ändern der JOIN-Abfrage in redaxo schon durch und kann uns da sicher weiterhelfen. Wir wären für eine professionelle Hilfe sehr dankbar.

Liebe Grüße
Matthias Lange
Agentur LOK.

Benutzeravatar
Markus.Staab
Entwickler
Beiträge: 9634
Registriert: 29. Jan 2005, 15:50
Wohnort: Aschaffenburg/Germany
Kontaktdaten: ICQ Website

18. Jan 2007, 19:06

Hi Matthias,

die JOINs im Kern sollten alle auch mit MySQL5 funktionieren.. Evtl musst du da in Addons schauen, aber im Kern sollte alles so gehen.

Wieso nicht einfach auf MySQL 4.x umstellen oder evtl mal in den Serversettings schauen, obs da ne einstellung gibt um die Abwärtskompatibilität zu aktivieren.

Gruß,
Markus

Benutzeravatar
Koala
Beiträge: 1612
Registriert: 3. Okt 2005, 13:20

Re: JOIN Problem unter MySQL 5.0.18

19. Jan 2007, 00:54

matthias hat geschrieben:Derzeit erscheint bei uns in Redaktionsbereiche redaxo keine Modultitel. Wenn man als eine Seite aufruft dann sind zwar drei Module enthalten aber der eigentlich fett markierte Modultitel fehlt und ist leer. Das Modul funktioniert aber beim Aufruf editieren. Es gibt noch an anderen Stellen (Bild einfügen, eigene Auflistung) ein seltsames verhalten.
Bevor hier wilde Spekulationen zum Redaxocode aufkommen mal ne Frage.
Wie sieht denn bei dir der HTML-Code der im Browser ausgegebenen Seite an der Stelle aus, an der die Modulüberschrift stehen müsste? (also alles direkt vor dem Editiern/Löschen-Text)
matthias hat geschrieben:Wir befürchten, das wir die MySQL-JOIN-Abfrage überall ändern müssen (wie im oberen Link beschrieben). Jetzt sind wir uns aber nicht sicher. Ob das so einfach geht.
Dürfte in dem Falle unnötig sein.
Schau mal in die Datei redaxo/include/classes/class.article.inc.php so ca. Zeile 200. Da steht

Code: Alles auswählen

    //print $sql;
Entferne die Slashes und du siehst über dem Modul die SQL-Ausgabe. das kopiert und in PHPMyAdmin ausgeführt müsste dir in der 2. Spalte den Modulnamen ausgeben.
<?php print $Footer; ?>

Sven

Ich würde ja die Welt verändern,
doch der Quellcode ist mir zu absurd!


REX 5 :: Tricks und Tipps
REX 5 :: Modulesammlung

Wiki zu Redaxo 3 und 4 (!nur noch im Webarchiv!)

matthias
Beiträge: 4
Registriert: 18. Jan 2007, 14:33

Re: JOIN Problem unter MySQL 5.0.18

22. Jan 2007, 10:28

Hallo,
vielen Dank für Eure Mühe. Das Problem liegt wohl wirklich bei der hohen MYSQL-Version, und dem Umgang mit 'JOIN'. Wir hier beschrieben http://wiki3.redaxo.de/index.php?n=R3.FAQ#mysql5 (Abschnitt "Joins ab MySQL 5.0.12") klappt das mit dem Join wohl nicht so richtig in unserer 5.0.18 Version.

Die entsprechenden Stellen, also da wo zum Beispiel der Modulname stehen sollte, sind im HTML-CODE leer. Gleiches gilt auch für andere Bereiche (zum Beispiel REX_FILE) in der schlicht und ergreifend die Werte aus der Datenbank einfach fehlen. Wohlgemerkt, redaxo läuft problemlos und die Werte sind im Modul vorhanden aber es fehlt der Modultitel und wenn man ein Bildmodul benutzt, dann steht der Wert korrekt drin aber er wird nicht im Frontend ausgegeben.

Wir sind jetzt kurz auf 4.1xxx zurückgegangen und da hat alles geklappt, dank der robusten Struktur von redaxo ist das ja kein Problem. Leider kennen wir uns mit den Joins nicht so gut aus. Ich werde jetzt aber mal die 5er-Version nehmen um das zu testen. Die "print $sql"-Geschichte werde ich jetzt auch mal ausprobieren.

Danke für Eure Mühe...

Liebe Grüße
Matthias

Zurück zu „Allgemeines [R3]“